Bug report #3604

paste doesn't convert geometry or give error on incompatible geometry

Added by William Kyngesburye over 8 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:13663

Description

For example, I'm working in a PostGIS multipolygon layer. I copy a polygon (not multi) from a shapefile and paste it into the postGIS layer. QGIS doesn't give me a warning or convert the polygon to a multipolygon, and editing works fine on the feature. But when I try to save the PostGIS layer, QGIS now gives me an error that there is an invalid geometry type and a feature wasn't saved (the one I pasted in).

I would like it to convert the polygon to multipolygon, and other simple conversions. But at least QGIS should refuse to paste and give a warning about a geometry mismatch.

Associated revisions

Revision 2f2d6ac9
Added by Jürgen Fischer almost 6 years ago

Merge pull request #1120 from 3nids/pasteconvertgeom

copy/paste: try to convert geometries (fixes #3604)

History

#1 Updated by William Kyngesburye over 8 years ago

Hmm, it looks like even copying from a multipolygon layer (both shapefile and another PostGIS layer) is not working. I still get invalid geometry.

#2 Updated by William Kyngesburye over 8 years ago

Now at least copying from a similar postgis multipolygon layer seems to be working. Still can't copy from the shapefile.

#3 Updated by William Kyngesburye over 8 years ago

Definitely something with copying from a shapefile to postgis. I converted the shapefile to a multipolygon postgis layer outside QGIS, added that layer to QGIS, and copy from that to my postgis layer works.

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#6 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF