Bug report #3549

Getting incomplete results from Intersect tool (fTools)

Added by gcarrillo - over 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System:Debian Easy fix?:
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13609

Description

On r15297 I get incomplete number of polygons when intersecting with the Geoprocessing tool 'Intersect' from fTools.

I attach two shapefiles for testing purposes.

In the command line I get this error:
---------------------
ERROR 1: Attempt to write non-polygon (MULTILINESTRING) geometry to POLYGON type shapefile.
---------------------

test_shps.tar (70 KB) gcarrillo -, 2011-03-06 11:33 AM

Associated revisions

Revision 4295a687
Added by Alexander Bruy over 7 years ago

Merge pull request #150 from slarosa/master

fix #3549

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Salvatore Larosa over 7 years ago

  • Assignee deleted (cfarmer -)
  • Pull Request or Patch supplied set to No
  • Status changed from Open to Feedback

It occurs because the intersection operation generates different geometries types!
In your case, it generates a MultiLineString geometry and try to write in a Polygon geometry.
I sent a pull request that should fix it!

#4 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Feedback to Open
  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Alexander Bruy over 7 years ago

  • Status changed from Open to Closed

#6 Updated by Alexander Bruy over 7 years ago

  • Resolution set to fixed

#7 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF