Bug report #3299

Crash loading Mapinfo tab file with non-spatial features

Added by Alister Hood almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:13359

Description

QGIS often crashes when loading .tab files.
The offending files are added to the layer control, but without a symbology row. If I click to turn the layer on, it crashes. I'll attach the error messages output by Debugview.

I think the problem is when a tab file contains features without any geometry, even if there are other features in the file that do have a geometry.

I'll attach an example .tab file that causes the crash

qgis_log.txt Magnifier - error messages output by debugview (5.99 KB) Alister Hood, 2010-12-06 04:31 PM

Desktop.zip - example Mapinfo tab file that causes the crash (1.21 KB) Alister Hood, 2010-12-06 04:32 PM

History

#1 Updated by Paolo Cavallini over 9 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Please check again with a fresh install and reopen in necessary. It works for me.

#2 Updated by Alister Hood over 9 years ago

Yes, it seems to work now :)

Also available in: Atom PDF