Bug report #3228

List of widgets not working with custom ui forms

Added by pinux - almost 10 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Forms
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:13288

Description

I have tried a lot of different widgets with customs ui forms and I have found that:

1. A column that is set as Unique value and i editable is not working with the custom ui form (I have tried with and without setting the combo box as editable)

2. The Calendar is not working with: Date Edit, Date/Time Edit and Calendar widgets. Not only it is not working, but the widget that is usually automatically created is present in the custom form. See the attachment.

calendar_widget.png (18.8 KB) pinux -, 2010-11-18 05:29 AM

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Nathan Woodrow over 8 years ago

  • Pull Request or Patch supplied set to No
  • Assignee changed from nobody - to Nathan Woodrow

#4 Updated by Nathan Woodrow over 8 years ago

Should be pretty easy to add support for the calendar, datetime, time pickers

#5 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Digitising to Forms
  • Operating System deleted (Windows)
  • Status info deleted (0)

#8 Updated by Nathan Woodrow over 5 years ago

  • Assignee deleted (Nathan Woodrow)

#9 Updated by Matthias Kuhn over 5 years ago

  • Status changed from Open to Closed

The whole edit widget part has seen a major refactoring since this issue was opened. Due to low activity here I suppose this is solved.

Please re-open if this is still an issue.

Also available in: Atom PDF