Feature request #3039

symbol levels ignored for rule based rendering

Added by Mayeul Kauffmann about 9 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:Symbology
Pull Request or Patch supplied:No Resolution:fixed
Easy fix?:No Copied to github as #:13099

Description

Using the new symbology with rule based rendering, symbol levels are ignored

Step to reproduce: have some roads with two layers for the symbols.
Click on "Symbol levels". Check "Activate symbol levels". Define levels.
Click OK, then apply. Symbol levels are not applied.
------------------------------------------
Related bug: Just after defining symbol levels and clicking apply:
Click on "Symbol levels" again, levels defined are still there.
Click OK; click OK again to close the layer property.
Click on "Symbol levels". They are gone.

History

#1 Updated by Mayeul Kauffmann about 9 years ago

Same bug as on version 1.5.0 tested today on latest trunk version 1.6.0

#2 Updated by Marco Hugentobler about 9 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

This is addressed in patch #2832

#3 Updated by Mayeul Kauffmann over 8 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (duplicate)

Hi, this has never been solved and was closed by mistake (the following comment acknowledged that symbol levels are ignored for rule based rendering:
http://trac.osgeo.org/qgis/ticket/2832#comment:7 )

And in fact, symbol levels are still ignored. As I wrote in the mailing list, for now, all NG renderers (Single symbol, categorized, graduated) have a working "Symbol level" button, except the rule-based renderer (which has a non-working) button ; the patch at #3222 will give similar behaviour on all renderers.
For the moment we have a button that does nothing.
jctull is correct here: http://trac.osgeo.org/qgis/ticket/2832#comment:11 : "We still don't get the symbol levels"

Reference to discussion:
http://osgeo-org.1803224.n2.nabble.com/symbol-levels-in-rule-based-rendering-tt6081768.html#a6113136
http://osgeo-org.1803224.n2.nabble.com/symbol-levels-in-rule-based-rendering-tt6081768.html#a6092502#none

#5 Updated by Anita Graser over 8 years ago

  • Priority changed from Low to Normal

#6 Updated by Paolo Cavallini over 8 years ago

  • Pull Request or Patch supplied set to No

Confirmed here: can we apply the patch?

#7 Updated by Paolo Cavallini over 8 years ago

  • Pull Request or Patch supplied changed from No to Yes

#8 Updated by mattwigway . about 8 years ago

It's still in 1.7.0-5 RPM from Fedora Project; is it in trunk?

#9 Updated by Mayeul Kauffmann about 8 years ago

  • Target version changed from Version 1.7.0 to Version 2.0.0

Hi,
This is (mostly) solved in QGIS 1.7.0 since this:
https://github.com/qgis/Quantum-GIS/pull/7

This is not yet in master.

#10 Updated by Nathan Woodrow about 8 years ago

Can we close this now? The same stuff from https://github.com/qgis/Quantum-GIS/pull/7 is now in master.

#11 Updated by Mayeul Kauffmann about 8 years ago

Hi,
I wrote "mostly" solved as the patch only partly solves the issue: it is still impossible to have symbol levels and more than the first matching rule.
Mayeul

#12 Updated by Giovanni Manghi almost 8 years ago

mayeul kauffmann wrote:

Hi,
I wrote "mostly" solved as the patch only partly solves the issue: it is still impossible to have symbol levels and more than the first matching rule.
Mayeul

Do the latest work by Martin on the rule based renderer fix definitely this issue?

#13 Updated by Mayeul Kauffmann almost 8 years ago

  • Status changed from Feedback to Closed

Issue solved, thanks Martin!

#14 Updated by Mayeul Kauffmann almost 8 years ago

  • Resolution set to fixed
  • Pull Request or Patch supplied changed from Yes to No

Also available in: Atom PDF