Bug report #3028

Displacement between vector and WMS layers after printing

Added by dr - about 9 years ago. Updated about 8 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:13088

Description

Open vector layer and WMS layer from any WMS Server (for example "osm" layer from "http://wms.latlon.org/?" server). In View all looks fine. Create new print composer and add map to it. All looks fine again. But after printing to pdf or to image we get displacement between vector and wms layers. It was tested on different wms servers and vector layers with different CRSs. See attachment.

21.09.png (236 KB) dr -, 2010-09-21 08:22 AM

nada01_1-4_100dpi_raster_win2k.pdf (126 KB) Thaddeus -, 2011-02-28 10:38 AM

nada01_1-4_100dpi_vector_win2k.pdf (111 KB) Thaddeus -, 2011-02-28 10:39 AM

nada01_1-6_100dpi_vector_win2k.pdf (210 KB) Thaddeus -, 2011-02-28 10:39 AM

nada01_1-6_100dpi_raster_win2k.pdf (128 KB) Thaddeus -, 2011-02-28 10:40 AM

nada01_1-5_100dpi_vector_win2k.zip (236 KB) Thaddeus -, 2011-02-28 10:41 AM

nada01_1-5_100dpi_raster_win2k.pdf (128 KB) Thaddeus -, 2011-02-28 10:41 AM

1-6-test.zip (26 KB) Thaddeus -, 2011-02-28 10:46 AM

ask2-qgis.pdf (1.82 MB) Nikos Tzelepis, 2011-07-15 07:09 AM

ask3-qgis.pdf (1.58 MB) Nikos Tzelepis, 2011-07-15 07:09 AM

TestData__Single_band_properties__LayerMisplacement.zip (173 KB) Thaddeus -, 2011-08-04 03:25 PM

Associated revisions

Revision 55a1778b
Added by Jürgen Fischer over 8 years ago

other workaround for Qt#5114 (fixes #3250, #3028, #2598)

Revision 908a494b
Added by Jürgen Fischer over 8 years ago

other workaround for Qt#5114 (fixes #3250, #3028, #2598)

History

#1 Updated by dr - about 9 years ago

The same problem when print simple raster and vector layers - in print composer all looks fine, but after export to pdf considerable displacement is presented.

#2 Updated by Alexander Bruy about 9 years ago

Problem with WMS confirmed on Linux with QGIS 1.6.0

#3 Updated by Jürgen Fischer about 9 years ago

Does "Print As Raster" help?

#4 Updated by dr - about 9 years ago

Print as raster doesn't help. I try to print map as raster to A2 paper size PDF and get displacement again.

#5 Updated by Jürgen Fischer over 8 years ago

see also #3448

#6 Updated by Thaddeus - over 8 years ago

I also have the same wrong displacement problem under Win using 1.6 and 1.5 and exporting as vector, but it does not happen with QGIS 1.4. Raster works OK. The vector PDF output (QGIS 1.6 Win) has other problems too, it is completely bloated with strange huge images not found on the source file: just printing an empty file with nothing on it, nil, nada, creates an 9MB (unzipped streams) PDF file having 3 large streams with images and one stream with badly malformed PS code. Under Ubuntu, the exported vector PDF output is not usable because the PC freezes for 5 minutes trying to draw a simple line of text on the screen due to PostSript rendering problems.

#7 Updated by Thaddeus - over 8 years ago

Here is some test data:

1-6-test.zip
the QGS test file has two layers, an raster image showing a well defined edge --nice for hand tracing-- and a line-SHP layer with the trace of the raster layer: 8 small files in total.

PDF's contain the export-to-PDF result under Win2k using QGIS 1.4, 1.5, 1.6..

Best exported PDF is the vector QGIS 1.4 printout, but has no vector data though.

#8 Updated by Marco Hugentobler over 8 years ago

Is this still true? Tested with current trunk and the attached dataset and the pdf export seems to look the same on map, in composer and in pdf.

#9 Updated by Jürgen Fischer over 8 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

closing for the lack of feedback.

#10 Updated by Nikos Tzelepis over 8 years ago

I found the same problem when trying to export map compositions with point symbols, in two different cases (just simple shapefiles).

#11 Updated by Nikos Tzelepis over 8 years ago

..with version 1.7. Was there any fix since the release date (19/6/2011) I should try?

#12 Updated by Thaddeus - about 8 years ago

No, version QGIS 1.7.0 Wroclaw under Win still PDF-exports shifted layers and shapes as raster instead of PS vectors --non "Print as raster" option.

Using the Win print services results in an OK printout but all shapes are rasterized.

PDF export as raster works OK.

#13 Updated by Micha Silver about 8 years ago

I can verify that on Win7 - OSGeo4W installer - the shift of vector layers vs raster (ECW) still exists. The problem appears only in PDF export. When saving as image there;s no shift. And on the map canvas everything looks fine.
Thanks,
Micha

#14 Updated by Jürgen Fischer about 8 years ago

micha - wrote:

I can verify that on Win7 - OSGeo4W installer - the shift of vector layers vs raster (ECW) still exists. The problem appears only in PDF export. When saving as image there;s no shift. And on the map canvas everything looks fine.

Do you mean the problem still exists in master (aka qgis-dev in OSGeo4W)? That's where it should be fixed - 1.7.0 doesn't have that fix.

#15 Updated by Thaddeus - about 8 years ago

Just made a quick check on QGIS 1.7.1 and it works great: no displacement anymore and I the SHP is rendered as PS stream (vector): excelente work !

Also available in: Atom PDF