Bug report #3448

Basic Printing not Properly Working under Windows.

Added by Thaddeus - over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13508

Description

I (Linux user) talked a few people (they use Win) into QGIS. The thing is that I never noticed this Composer print corruption before (only under Windows, prints OK under Linux, except for some extremely long, long, slow font-outline PS code --will make another ticket for that).

To reproduce (use qgis 1.5 or 1.6 under win2k, xp, 7):

1) open geo-referenced raster (on the fly CRS on).
2) trace any thing on it using shp line.
3) open composer, add 1 object, a map rectangle & use defaults (A4, 300dpi)
4) export to PDF as vector.
5) review output PDF: image is off place some inches and PDF file is huge* in size having weird manufactured image streams inside and the shp trace is an image.

  • after unzipping streams using PDFtk.

Does NOT happen with QGIS 1.4.

PrintCorruption_CanvasAfterReopening.png - Screenshot (27.7 KB) Thaddeus -, 2011-01-28 02:29 PM

PrintCorruption_OutoutPDF.png - Screenshot (73.7 KB) Thaddeus -, 2011-01-28 02:30 PM

PrintCorruption_Composer.png - Screenshot (33.1 KB) Thaddeus -, 2011-01-28 02:30 PM

PrintCorruption_Canvas.png - Screenshot (55.5 KB) Thaddeus -, 2011-01-28 02:31 PM

1-6-test.qgs - The qgs file (27.8 KB) Thaddeus -, 2011-01-28 02:31 PM

1-6-test_LowRes_100dpi.pdf - Low Res. Exported PDF (3 MB --when opened-- for 450kB of source data) (210 KB) Thaddeus -, 2011-01-28 02:43 PM

1-6-test_LowRes_100dpi.2.pdf - Low Res. Exported PDF (3 MB --when opened-- for 450kB of source data) (210 KB) Thaddeus -, 2011-01-28 02:43 PM

History

#1 Updated by Jürgen Fischer over 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3028.

Also available in: Atom PDF