Bug report #2598

Polygon fill patterns scale differently in pdf export as raster versus non-raster

Added by John Tull over 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:
Crashes QGIS or corrupts data: Copied to github as #:12658

Description

When I print to a pdf file with the "as raster" option selected, polygon fill patterns appear as I would expect. If I, instead, export the pdf as a vector file, the fill patterns are quite oversized/enlarged and appear pixelated. For example, using cross-hatch patterns looks quite different on the finalized map that is exported between the two methods. I believe this is true for both old and new symbology. qt-4.6.2

Associated revisions

Revision 55a1778b
Added by Jürgen Fischer over 8 years ago

other workaround for Qt#5114 (fixes #3250, #3028, #2598)

Revision 908a494b
Added by Jürgen Fischer over 8 years ago

other workaround for Qt#5114 (fixes #3250, #3028, #2598)

History

#1 Updated by Marco Hugentobler over 9 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is a Qt but (http://bugreports.qt.nokia.com/browse/QTBUG-5114). It works if you print to raster because QPainter then renders to image first and then embedds the image into the pdf.
No idea why the patch in the ticket is not applied to the qt sources. I tested with a patched Qt and it worked properly.

And note: it only works for symbology-ng 'svgFill' types. The hardcoded polygon fill hatches are printed as raster by QBrush, so won't scale nicely on printout.

Closing the ticket because it is not a bug in QGIS (though I understand it is annoying for users).

#2 Updated by John Tull over 9 years ago

Thanks for your comments on this, Marco. I recall, vaguely, that we discussed this in email at some point in the past. Your clarification is useful and should help others that might come across this issue.

#3 Updated by Jürgen Fischer over 8 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (wontfix)

#4 Updated by Jürgen Fischer over 8 years ago

  • Resolution set to upstream
  • Status changed from Feedback to Closed

Also available in: Atom PDF