Bug report #2971

Trunk r14153 - Turning an empty layer on and off zooms the map overview in and out

Added by Alister Hood about 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13031

Description

(This is using the r14153 build from the osgeo installer; please tell me if we aren't really supposed to report bugs against these builds)

If I have a layer (only tested with shapefiles) with no objects in it, the map zooms in and out when I turn it on and off.

This is disconcerting mostly because it occurs after I use Layer->New->New Shapefile layer.

History

#1 Updated by Alister Hood about 9 years ago

Sorry; I forgot to say this doesn't occur in 1.5.0.

#2 Updated by Anne Ghisla over 8 years ago

Is it reproducible with more recent builds?

#3 Updated by Alister Hood over 8 years ago

No, now it only zooms the overview in and out ;)

Good catch.

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Nathan Woodrow over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No

No longer a issue in master (2.4). Reopen if you see it happen again.

Also available in: Atom PDF