Bug report #2802

georeferencer plug-in produce wrong results

Added by epifanio - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12862

Description

he georeferencer results give me a broken or not-well georeferenced image.
I tried more than one georef-mode, helmert tsp, linear ... both gived me a wrong results (the pdf report font/layout size, is ok).

I tried to georeference a an already georeferenced image (gtiff). seems the problem is in "srcY" that has a negative sign, see : http://img811.imageshack.us/f/didefault20100612a14573.png/ ???

i tried on revision : r13719

this the lines generated by the "genate gdal script" :

gdal_translate of GTiff -gcp 407856 -4.51152e+06 407850 4.51146e+06 -gcp 412362 -4.50949e+06 412405 4.50945e+06 -gcp 403813 -4.50763e+06 403773 4.5077e+06 -gcp 406646 -4.50593e+06 406637 4.50597e+06 -gcp 410560 -4.50663e+06 410516 4.50669e+06 -gcp 403993 -4.51044e+06 403932 4.51049e+06 -gcp 410740 -4.51075e+06 410734 4.51074e+06 -gcp 403324 -4.50707e+06 403335 4.50712e+06 -gcp 409015 -4.50568e+06 409044 4.50569e+06 -gcp 411641 -4.50601e+06 411669 4.50605e+06 "/Users/sasha/Desktop/cleandesk/landsat/tm5_landsat/1993/ischia/ischia_5dt19930823_z33_10.tif" "/var/folders/G7/G7KYb9O2GaGW2zFTZZP9nE+++TI/-Tmp/ischia_5dt19930823_z33_10.tif"
gdalwarp r near -tps -co COMPRESS=NONE -dstalpha "/var/folders/G7/G7KYb9O2GaGW2zFTZZP9nE+++TI/-Tmp/ischia_5dt19930823_z33_10.tif" "/Users/sasha/Desktop/h.tif"

this is the image i'm tring to georeference : http://www.geofemengineering.it/data/ischia_5dt19920820_z33_10.tif (200 kb)

History

#1 Updated by Paolo Cavallini over 11 years ago

I use it regularly, and found no problem. More investigation needed to check if it's replicable.

#2 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

should be duplicate of #2465

reopen if necessary.

Also available in: Atom PDF