Bug report #2482

Interpolation plugin causes seg fault

Added by Giovanni Manghi over 9 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:Marco Hugentobler
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:12542

Description

Tested on both linux and windows xp with the following point vector

http://mapserver.uevora.pt/~mapserver/dados.rar

I mistakenly choose this point layer to create a TIN (points extracted from a altimetry line vector, so not really suited for the analysis), but I believe that a error message should be thrown instead of the crash. Nevertheless close the ticket if you consider this situation too extreme.

test2.xyz (2.73 MB) Tristan Allouis, 2012-05-25 01:43 AM


Related issues

Duplicated by QGIS Application - Bug report #5239: TIN interpolation causes crash Closed 2012-03-26

History

#1 Updated by Marco Hugentobler over 9 years ago

I have problems accessing the sample file (server connection times out).

#2 Updated by Giovanni Manghi over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Hi,
sorry for the broken link. I tested the tool again with what I believe is a vector identical to the one linked and it works fine now. So I'll close this then I'll test the linked vector and leave further feedback if necessary.

#3 Updated by Giovanni Manghi over 9 years ago

The link is working again, and running the interpolation plugin against this vector crashes qgis.

#4 Updated by Marco Hugentobler over 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (invalid)

ok, I have the testdata now and can reproduce the bug.

#5 Updated by Paolo Cavallini almost 9 years ago

Data are no longer available. Any hope of having this fixed?

#6 Updated by Paolo Cavallini almost 9 years ago

Duplicated in #2988

#7 Updated by Giovanni Manghi almost 9 years ago

I can provide the data again. Marco has it in any case. The crash was confirmed but I don't know if anything has been done yet.

#8 Updated by Anne Ghisla over 8 years ago

I wish to replicate the bug, are the data available somewhere else? Can you share them, Marco?

#9 Updated by Alister Hood about 8 years ago

Here is a link for a (very large) contour shapefile which crashes my QGIS as soon as starting TIN interpolation. N.B. the interpolation plugin is not really suitable for large files (polyline files - I'm not sure about point files) anyway - it takes many hours to do an IDW interpolation, even at a low resolution.

http://dl.dropbox.com/u/24564149/0.1m_Contour_combined.zip

#10 Updated by Paolo Cavallini about 8 years ago

  • Pull Request or Patch supplied set to No
  • Start date set to 2011-07-25
  • Status changed from Feedback to Open
  • Tracker changed from Bug report to 4

#11 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#13 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to Yes
  • Subject changed from interpolation plugin causes seg fault to Interpolation plugin causes seg fault
  • Priority changed from Low to 6

New sample data

http://sengis.uni-hohenheim.de/tmp/interpolation_bug_tin.zip

from Martin Weis, who adds

"And here is a backtrace, it looks like there is a loop, I snipped a lot: http://paste.ubuntu.com/780464/ "

#14 Updated by Werner Macho over 7 years ago

  • Affected QGIS version set to master
  • Priority changed from 6 to Normal

Confirmed for http://dl.dropbox.com/u/24564149/0.1m_Contour_combined.zip which is very big data ..
but not for http://sengis.uni-hohenheim.de/tmp/interpolation_bug_tin.zip
neither on release-1_7 branch nor master branch ..
So it seems the problem only exists with very big data ..
Setting Priority normal as it seems not to be a showstopper for "normal" cases ..
Still the plugin seems not to handle big data very well

#15 Updated by Giovanni Manghi over 7 years ago

  • Tracker changed from 4 to Bug report

#16 Updated by Giovanni Manghi over 7 years ago

  • Status info deleted (1)
  • Priority changed from Normal to High
  • Operating System deleted (All)

possible duplicate of #5239 (that has a patch attached)

#17 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#18 Updated by Tristan Allouis over 7 years ago

Same problem: Segmentation fault using the "interpolation" plugin and the TIN method on a xyz dataset (Z interpolation).
I checked the patch attached in #5239 but it did not fix the problem.

According to my tests, qgis crashes when the points to interpolate are too close (too dense dataset).
I enclose a dataset that causing qgis to crash. Use the SCR ID 10090.

Please can you test this dataset and report if it crashes or not?

Thanks!

#19 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

merging this with #5239

Also available in: Atom PDF