Bug report #21230

QGIS master crash when using spatial indices

Added by Pedro Venâncio 12 months ago. Updated 12 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Windows Package
Affected QGIS version:3.5(master) Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:29048

Description

To reproduce:

1. Load a point layer (postgis, shp, ...)
2. Properties -> Symbology
3. Point Displacement OR Point Cluster
4. Apply
5. QGIS Crashed

QGIS Info
QGIS Version: 3.5.0-Master
QGIS code revision: 29d4496452
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.4.0
Running against GDAL: 2.4.0

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17763

This does not happened in code revision daab33c4d7 (3.5.0-84 in OSGeo4W).

In 3.4.4 this also does not happen.

sample.zip (1.95 KB) Pedro Venâncio, 2019-02-12 10:21 AM

History

#1 Updated by Giovanni Manghi 12 months ago

Confirmed here, only master.

#2 Updated by Nyall Dawson 12 months ago

no crash here - can you post data to reproduce?

#3 Updated by Nyall Dawson 12 months ago

  • Status changed from Open to Feedback

#4 Updated by Nyall Dawson 12 months ago

  • Category changed from Symbology to Windows Package
  • Status changed from Feedback to Open
  • Subject changed from QGIS master crash with Point Displacement or Point Cluster Symbology to QGIS master crash when using spatial indices

Actually the issue is ANYTHING which uses a spatial index -- snapping/vertex tool is also affected.

This is likely a consequence of the recent upgrade to libspatialindex 1.9

#5 Updated by Pedro Venâncio 12 months ago

Nyall Dawson wrote:

This is likely a consequence of the recent upgrade to libspatialindex 1.9

Hi Nyall,

I was checking OSGeo4W and it is still using libspatialindex 1.8.5-1.

And being a problem with libspatialindex package, should not also affect 3.4.4?

I see that after start editing the point layer, with Add feature tool, Vertex tool, Move feature, just moving the cursor over canvas, QGIS shows an Exception window with "unknown exception" message.

I attach a sample dataset.

#6 Updated by Giovanni Manghi 12 months ago

I see that after start editing the point layer, with Add feature tool, Vertex tool, Move feature, just moving the cursor over canvas, QGIS shows an Exception window with "unknown exception" message.

I filed #21237 yesterday about this issue.

#7 Updated by Pedro Venâncio 12 months ago

  • Status changed from Open to Closed

It is fixed now!

Thanks!

#8 Updated by Giovanni Manghi 12 months ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF