Bug report #21237

"unknown exception" when enabling editing

Added by Giovanni Manghi 12 months ago. Updated 12 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29055

Description

Seen on master/windows

add a vector

enabled snapping

toggle editing > pick node tool > see attached screenshot

VirtualBox_windows_7_11_02_2019_18_41_58.png (140 KB) Giovanni Manghi, 2019-02-11 07:42 PM

History

#1 Updated by Martin Dobias 12 months ago

Is it possible to get the data? And is the bug windows only? If snapping is disabled, there's no exception?

#2 Updated by Nyall Dawson 12 months ago

Martin - this is a packaging issue with the latest libspatialindex under windows

#3 Updated by Giovanni Manghi 12 months ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

osgeo4w got a libspatialindex update, now the issue is gone.

Also available in: Atom PDF