Bug report #21144

Snapping tooltips + advanced digitizing QGIS not responding

Added by Nikolai Krawczak 10 months ago. Updated 9 months ago.

Status:Open
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.7(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:28962

Description

A combination of snapping tooltips and advanced digitizing is not working. QGIS becomes unresponsive.

snapping_info.gif (1.35 MB) Nikolai Krawczak, 2019-01-31 05:13 PM

History

#1 Updated by Jan Lippmann 10 months ago

I can confirm. same issue today in my workshop...

#2 Updated by Giovanni Manghi 10 months ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Also on a new/clean profile (no 3rd party plugins installed)?

#3 Updated by Nikolai Krawczak 10 months ago

Giovanni Manghi wrote:

Also on a new/clean profile (no 3rd party plugins installed)?

yes, I used a fresh profile for confirmation.

#4 Updated by Nyall Dawson 10 months ago

I can't reproduce on Linux -- possible windows specific?

#5 Updated by Nikolai Krawczak 10 months ago

Nyall Dawson wrote:

I can't reproduce on Linux -- possible windows specific?

maybe even windows version specific - I can't reproduce on Win 10

#6 Updated by Jan Lippmann 10 months ago

In my case, it's an issue on Win 7 64 bit. Also with actual master.

#7 Updated by Jan Lippmann 10 months ago

I can confirm with NO issue on Linux...

#8 Updated by Almerio Moreira 10 months ago

I CAN confirm same issue with Windows 7 Professional 64 bits!

#9 Updated by Urs Kaufmann 10 months ago

I can confirm on Win 7 Prof, I can not confirm on Mac OS 10.14.3
But on both systems, QGIS crashes on exit, if I before used advanced digitizing and enabled snapping together

#10 Updated by Giovanni Manghi 10 months ago

But on both systems, QGIS crashes on exit, if I before used advanced digitizing and enabled snapping together

even on a new/clean profile (no 3rd party plugins installed)?

#11 Updated by Almerio Moreira 10 months ago

even on a new/clean profile (no 3rd party plugins installed)?

On a new/clean profile it worked fine on Windows 7, but I got the following issue on close:

Crash ID: 951373503a103ea02a4b994f442bf9beef9027b4

Stack Trace

QgsSnapIndicator::~QgsSnapIndicator :
QgsAdvancedDigitizingCanvasItem::~QgsAdvancedDigitizingCanvasItem :
QgsAdvancedDigitizingDockWidget::CadConstraint::operator= :
QgsMapCanvas::~QgsMapCanvas :
QgsVectorLayerProperties::`default constructor closure' :
QgisApp::~QgisApp :
CPLStringList::operator[] :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

#12 Updated by Urs Kaufmann 10 months ago

But on both systems, QGIS crashes on exit, if I before used advanced digitizing and enabled snapping together

even on a new/clean profile (no 3rd party plugins installed)?

Yes, the crash is also on a new profile

#13 Updated by Giovanni Manghi 10 months ago

  • Status changed from Feedback to Open

#14 Updated by Giovanni Manghi 10 months ago

Almerio Moreira wrote:

even on a new/clean profile (no 3rd party plugins installed)?

On a new/clean profile it worked fine on Windows 7, but I got the following issue on close:

so the issue described here does not show on a new/clean profile?
the crash on exit is probably unrelated, and there are a ton of other similar reports about it.

#15 Updated by Giovanni Manghi 10 months ago

  • Status changed from Open to Feedback

#16 Updated by Jan Lippmann 10 months ago

i can confirm nikolai..

its an issue on a new/clean profile (no 3rd party plugins installed!) AND WIN 7!

there is no crash with the crashreport window...qgis freeze/hang and takes cpu time and eat's ram while hanging...

#17 Updated by Almerio Moreira 10 months ago

Giovanni Manghi wrote:

Almerio Moreira wrote:

even on a new/clean profile (no 3rd party plugins installed)?

On a new/clean profile it worked fine on Windows 7, but I got the following issue on close:

so the issue described here does not show on a new/clean profile?
the crash on exit is probably unrelated, and there are a ton of other similar reports about it.

I have no problem with a clean profile on Win 7, but this Crash on exit is for sure related to the combination of advanced digitizing and enabled snapping together, as you can see on stack trace I posted on #11 and for many tests I did.

#18 Updated by Giovanni Manghi 10 months ago

  • Status changed from Feedback to Open

#19 Updated by Urs Kaufmann 10 months ago

My experience: the effect of the clean profile is, that the "show snapping tooltips" is off (as shown in the video above). If I turn on and off these snapping tooltips in "old" profiles I can control the freezing (so turn it off). But I can not control the crash on exit QGIS...

#20 Updated by Almerio Moreira 10 months ago

Urs Kaufmann wrote:

My experience: the effect of the clean profile is, that the "show snapping tooltips" is off (as shown in the video above). If I turn on and off these snapping tooltips in "old" profiles I can control the freezing (so turn it off). But I can not control the crash on exit QGIS...

Yes, you are right!!!
By turning off snapping tooltips it works good even with "Dirty" profile!
But the crash on exit continues

#21 Updated by Jochen Schwarze 9 months ago

Observed the same issue with 3.4.5 LTR, 3.6.0 and 3.7.0 on WIN 10, no 3rd party plugins installed.

#22 Updated by Giovanni Manghi 9 months ago

  • Affected QGIS version changed from 3.4.4 to 3.7(master)
  • Regression? changed from No to Yes

Also available in: Atom PDF