Bug report #2081

Old Symbology: different rotation of symbol and label

Added by 6896896 - almost 10 years ago. Updated about 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:12141

Description

Rotation angle for label of vector feature is in Arithmetic system (rotate left) in degree.
Rotation angle for symbol (point) is in Geographic system(rotate right) in degree.

Is possible unity both to one, rather geographic system (right hand rotating).

Order:
1. add vector point layer (i.e. SHP)
2. "open/properties/symbology" field rotation to numeric column in table
3. "open/properties/lables/data defined alignment" field angle to same numeric column in table
4. see on the map, rotation symbol and label is differend


Related issues

Duplicated by QGIS Application - Bug report #4294: Symbol and text rotation/placement errors Closed 2011-09-19

History

#1 Updated by Volker Fröhlich over 8 years ago

It still is this way with old symbology and old labeling.

New symbology still rotates labels clockwise, rotation in new labeling seems to be disabled.

#2 Updated by Anita Graser almost 8 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)
  • Subject changed from different rotation of symbol and label to Old Symbology: different rotation of symbol and label

#3 Updated by Giovanni Manghi almost 8 years ago

are we sure we want to keep open tickets on old symbology and old labelling? Both will be removed in QGIS 2.x, AFAIK

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Daniel Vaz about 6 years ago

Is this still valid for new version 2.0.0 ?

Thanks in advance

#8 Updated by Nathan Woodrow about 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Old symbology is no longer supported in 2.0.

Also available in: Atom PDF