Bug report #4294

Symbol and text rotation/placement errors

Added by Andrew Chapman about 8 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14231

Description

The attached project and layer shows several problems using old and new symbology plus old with old and new labels.
1) Rotation of (old) label is anticlockwise, but symbols rotate anticlockwise - they both sould go the same way.
2) New label doesn't rotate
3) Rotation field for new label needs values for position (distance, X & Y) before rotation is enabled
4) Old label doesn't centre text on anchor point - too low vertically

Rotation_bug.zip - Sample project and layer (10.5 KB) Andrew Chapman, 2011-09-19 01:20 PM


Related issues

Duplicates QGIS Application - Bug report #2081: Old Symbology: different rotation of symbol and label Closed

History

#1 Updated by Andrew Chapman about 8 years ago

This may mainly be a duplicate of #2081

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Daniel Vaz about 6 years ago

As mentioned above, it is a duplicate of #2081.

Please, close this and keep watching in #2081

Thanks in advance.

#6 Updated by Daniel Vaz about 6 years ago

  • Status changed from Open to Closed

#2081 was closed because old symbology was no longer support in 2.0.0

I will close it too, please reopen if necessary.

Also available in: Atom PDF