Feature request #19875

Deleting multiple GPKG tables from Browser only deletes a single table

Added by Jérôme Guélat about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Browser
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:27699

Description

It would be really nice to be able to delete several GeoPackage tables simultaneously in the browser using the following workflow:

1. Select several tables in a GeoPackage
2. Right-click and choose delete layers
3. All the selected tables are deleted

Thanks in advance!

History

#1 Updated by Alessandro Pasotti about 2 years ago

  • Crashes QGIS or corrupts data set to No
  • Regression? set to No
  • Subject changed from Browser: delete several GeoPackage tables with one click to Deleting multiple GPKG tables from Browser only deletes a single table
  • Assignee set to Alessandro Pasotti
  • Affected QGIS version set to 3.3(master)
  • Tracker changed from Feature request to Bug report

This is actually a bug: when you select multiple tables from the browser only the layer where the right click happened is deleted.

#2 Updated by Alessandro Pasotti about 2 years ago

  • Tracker changed from Bug report to Feature request
  • Priority changed from Normal to High

btw, it's not trivial implementation and it would require API changes because currently all actions associated with the contextual menu have no knowledge of selected items in the browser tree and we'd need to pass them down the call stack.

I'm setting it back to feature request but raising the priority to high.

#3 Updated by David Signer almost 2 years ago

Are you working on that Alessandro? Do you want to keep it?
Otherwise I could probably care about in the next days/weeks...

#4 Updated by Alessandro Pasotti almost 2 years ago

No, I'm busy on other stuff, please go ahead, now it's definitely possible (and much easier) to implement this, after Nyall's recent small refactoring of the browser data item providers.

Thanks!

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee deleted (Alessandro Pasotti)

#6 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in 3.6

Also available in: Atom PDF