Bug report #19761

Unable to close QGIS because of an (ghost?) active task

Added by Harrissou Santanna over 1 year ago. Updated 10 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:3.3(master) Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27586

Description

I'm trying to close QGIs hitting the X button but fail with an "Active Tasks" dialog that pops up stating that Identify features tool is being busy (attached image). Any choice I do in this dialog does not help to close QGIS.
Also notice that clicking on the status bar I see the Identify features task in the list but at 100% and, anyway looks like I can't interact with this widget.

I finally had to force quit.

task_completed.png - Unable to interact with the widget (10.3 KB) Harrissou Santanna, 2018-09-03 07:33 PM

cancel_Identify.png - dialog with the blocking message (9.3 KB) Harrissou Santanna, 2018-09-03 07:33 PM


Related issues

Related to QGIS Application - Bug report #20459: QGIS freezes on Identifying Features Closed 2018-11-12

Associated revisions

Revision 5b04719b
Added by Nyall Dawson 10 months ago

Fix stuck tasks when proxied task using a proxy progress task
completes before the proxy task has been started by task manager

Fixes #21589, fixes #19761

Revision b28227fa
Added by Nyall Dawson 10 months ago

Fix stuck tasks when proxied task using a proxy progress task
completes before the proxy task has been started by task manager

Fixes #21589, fixes #19761

Revision 66504fe0
Added by Nyall Dawson 10 months ago

Fix stuck tasks when proxied task using a proxy progress task
completes before the proxy task has been started by task manager

Fixes #21589, fixes #19761

(cherry picked from commit b28227fa7f946e0c0ccba1b588a8ac47fef0c85f)

Revision e300042e
Added by Nyall Dawson 10 months ago

Fix stuck tasks when proxied task using a proxy progress task
completes before the proxy task has been started by task manager

Fixes #21589, fixes #19761

(cherry picked from commit b28227fa7f946e0c0ccba1b588a8ac47fef0c85f)

Revision e75b934e
Added by Nyall Dawson 10 months ago

Fix stuck tasks when proxied task using a proxy progress task
completes before the proxy task has been started by task manager

Fixes #21589, fixes #19761

(cherry picked from commit b28227fa7f946e0c0ccba1b588a8ac47fef0c85f)

History

#1 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Feedback

Can you reproduce this? I need some more info here.

#2 Updated by Harrissou Santanna over 1 year ago

  • Status changed from Feedback to Open

Yes, right now!
Can you tell me the kind of information you need because I'm not sure I did something particular and I'm pretty sure the identify actions are not the latest I do?

#3 Updated by Nyall Dawson over 1 year ago

I guess some steps to reproduce would help... I haven't been able to.

#4 Updated by Harrissou Santanna about 1 year ago

#5 Updated by Harrissou Santanna about 1 year ago

#6 Updated by Hans Omat about 1 year ago

Nyall Dawson wrote:

I guess some steps to reproduce would help... I haven't been able to.

It usually happens when we have identified a feature and then then pan/zoom the map to another position.
We only have Postgres connections in place - maybe that's worth to mention.

#7 Updated by Alexander Bruy about 1 year ago

#8 Updated by Nyall Dawson 10 months ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF