Bug report #20441

Unable to stop executing GDAL algorithm

Added by K S over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GDAL
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:28261

Description

Raster -> Conversion -> Polygonize (raster to vector).
This process was taking a very long time and I wanted to stop it.
I clicked the progress bar in the status bar below the main map view and tried clicking the red "X", but it does nothing.

Exit QGIS (CTRL+Q) prompts if I want to attempt to cancel the active task, but does not succeed at this.
My final solution was to terminate the QGIS process manually via Windows Task Manager.

Executing.png - The red "X" does nothing. (21.6 KB) K S, 2018-11-10 04:44 PM

Polygonize (Raster to Vector) - Log.txt Magnifier (479 Bytes) K S, 2018-11-10 04:44 PM

Active Tasks.png - Prompt upon Exit. (35.9 KB) K S, 2018-11-10 04:50 PM


Related issues

Related to QGIS Application - Bug report #18600: QGIS3: can't cancel ogr2ogr Closed 2018-03-31
Duplicates QGIS Application - Feature request #20060: Allow cancelling gdal algorithms Open 2018-10-09

Associated revisions

Revision b19e0bd5
Added by Alexander Bruy over 1 year ago

[processing] don't show cancel button in the task manager for algorithms that can not be cancelled (refs #20441)

Revision dddb32e3
Added by Alexander Bruy over 1 year ago

[processing] don't show cancel button in the task manager for algorithms that can not be cancelled (refs #20441)

(cherry picked from commit b19e0bd5d441b2584b663cac77073928c0314ff4)

History

#1 Updated by Harrissou Santanna over 1 year ago

  • Related to Bug report #19761: Unable to close QGIS because of an (ghost?) active task added

#2 Updated by Giovanni Manghi over 1 year ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Subject changed from Unable to stop executing algorithm. to Unable to stop executing GDAL algorithm
  • Category changed from Rasters to Processing/GDAL
  • Priority changed from Low to High

#3 Updated by Alexander Bruy over 1 year ago

  • Related to deleted (Bug report #19761: Unable to close QGIS because of an (ghost?) active task)

#4 Updated by Alexander Bruy over 1 year ago

#5 Updated by Alexander Bruy over 1 year ago

#6 Updated by Alexander Bruy over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Priority changed from High to Normal
  • Operating System deleted (Windows 7 x64)

Actually GDAL algorithms (as well as SAGA and GRASS) can not be cancelled, see #18600. Confusion comes from the fact that in QGIS task manager we still have a cancel button for them. Here is PR to fix this https://github.com/qgis/QGIS/pull/9026.

Closing this, as implementing cancellation support is a feature request and we already have #20060 for it.

Also available in: Atom PDF