Bug report #19727

[Print layout] Clicking the link in the message after a successful export no longer opens the folder

Added by Harrissou Santanna over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27552

Description

Export a print layout to whatever format (jpg, pdf...)
At the end of the process, you get a message that the file has been successfully exported and the path to the file.
Clicking the link does nothing while it used to, at least in 3.0, open the folder in which the file is stored.
Tested on W10, 304033c916.

Associated revisions

Revision a0dceb1d
Added by Nyall Dawson over 1 year ago

[layouts] Fix messagebar link with special characters does not open on win

Fixes #19727

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Priority changed from Normal to High

#2 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Feedback

I can't reproduce. Can you post instructions on how to replicate?

#3 Updated by Harrissou Santanna over 1 year ago

No real instructions needed; all is above. It's just about clicking the link in the notification after an export.
I did reproduce it a numerous time on the same (old) project, regardless the print layout, then tested successfully on another project and going back to the first project, it works after some trials.
I can't explain!

Let's keep the report open and if ever i reproduce the issue in upcoming days/week, i'll attach the culprit file and any needed settings information.

#4 Updated by Nyall Dawson over 1 year ago

Things to test would be stuff like exporting to paths with spaces/special characters, exporting to local/network paths, etc. There's likely a pattern to find...

#5 Updated by Harrissou Santanna over 1 year ago

  • Status changed from Feedback to Open

Good suggestion.
I Made some quick tests and it happens that spacing is not a problem but special characters (such as é, è...) are the culprits: clicking the path when such a character is available does not open the folder. Being on a network or not does not make a difference.

#6 Updated by Nyall Dawson over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF