Bug report #19706

The tool "Dissolve" doesnt weork properly in new version of QGIS (3.2.2)

Added by Amir Naj about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.2.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:27531

Description

When I want to use Dissolve tool, always the message below appears for me, since in previous version it was OK.

Processing algorithm…
Algorithm 'Dissolve' starting…
Input parameters: { 'FIELD' : [], 'INPUT' : 'Terranuova_Bracciolini_c27558ee_d8d1_4d83_812c_e2e4e215ef44', 'OUTPUT' : 'memory:' }

Execution completed in 0.03 seconds
Results: {'OUTPUT': 'output_74c340d1_d4ad_47c0_831f_0913fee5c8a2'}

Loading resulting layers
The following layers were not correctly generated.<ul><li>output_74c340d1_d4ad_47c0_831f_0913fee5c8a2</li></ul>You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

Test.cpg (5 Bytes) Amir Naj, 2018-08-28 12:09 PM

Test.dbf (868 Bytes) Amir Naj, 2018-08-28 12:09 PM

Test.prj (143 Bytes) Amir Naj, 2018-08-28 12:09 PM

Test.qpj (257 Bytes) Amir Naj, 2018-08-28 12:09 PM

Test.shx (380 Bytes) Amir Naj, 2018-08-28 12:09 PM

Test.shp (5.67 KB) Amir Naj, 2018-08-28 12:09 PM

History

#1 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

Can you share the layer you are trying to dissolve?

#2 Updated by Amir Naj about 2 years ago

#3 Updated by Amir Naj about 2 years ago

Nyall Dawson wrote:

Can you share the layer you are trying to dissolve?

Yes sure, I have uploaded the SHP "Test"

#4 Updated by Giovanni Manghi about 2 years ago

  • Priority changed from High to Normal
  • Category changed from Actions to Processing/Core
  • Assignee deleted (Amir Naj)
  • Crashes QGIS or corrupts data changed from Yes to No

Works fine here on master/linux and using the native QGIS dissolve tool. Did you tried another tool (gdal? saga? grass?)?

#5 Updated by Luigi Pirelli about 2 years ago

could be related the same issue as in #19700 ?

#6 Updated by Alexander Bruy almost 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to no timely feedback

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF