Bug report #19478

3.2 Crash on OSX High Sierra when using XYZ layers

Added by Frank Horowitz almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/XYZ
Affected QGIS version:3.2 Regression?:No
Operating System:OSX High Sierra Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:27306

Description

I'm experiencing repeatable crashes on zooming in (too far?) of XYZTile display of Google Hybrid map as lowest level.

Here is a cut-and-paste of the crash report that would be sent to Apple: < https://pastebin.com/wcF63b1p >.

Note that the guilty thread is crashing on a call to QRasterPaintEngine::drawImage(QRectF const&, QImage const&, QRectF const&, QFlags<Qt::ImageConversionFlag>)

It is moderately easy for me to trigger this bug, so I may be able to provide more details from a different crash.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from Normal to High

#2 Updated by Nathan Perry almost 2 years ago

I have this too; see: https://issues.qgis.org/issues/19544. The crash is repeatable but not (for me) predictable. In my case I'm using Google Satellite rather than Hybrid.

#3 Updated by Nathan Perry almost 2 years ago

Update: It appears I can avoid the crash as long as I don't zoom in beyond what looks like the tiles' native resolution (approx. 1:1500 scale at 2x magnification). Something to do with resampling, perhaps?

#4 Updated by Frank Horowitz almost 2 years ago

Nathan Perry wrote:

Update: It appears I can avoid the crash as long as I don't zoom in beyond what looks like the tiles' native resolution (approx. 1:1500 scale at 2x magnification). Something to do with resampling, perhaps?

That seems to be (at least) consistent with my experience. Zooming in too far somewhat-repeatably triggers the crash.

#5 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Nathan Perry wrote:

Update: It appears I can avoid the crash as long as I don't zoom in beyond what looks like the tiles' native resolution (approx. 1:1500 scale at 2x magnification). Something to do with resampling, perhaps?

does it happens only if the project contains xyz layers?

#6 Updated by Frank Horowitz almost 2 years ago

Giovanni Manghi wrote:

Nathan Perry wrote:

Update: It appears I can avoid the crash as long as I don't zoom in beyond what looks like the tiles' native resolution (approx. 1:1500 scale at 2x magnification). Something to do with resampling, perhaps?

does it happens only if the project contains xyz layers?

Yes, using an XYZ layer of the "Google Hybrid" (i.e. Air/satellite photos with roads overlain) is the only time I have observed this crash.

#7 Updated by Giovanni Manghi almost 2 years ago

  • Subject changed from 3.2 Crash on OSX High Sierra to 3.2 Crash on OSX High Sierra when using XYZ layers

#8 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#9 Updated by Nyall Dawson over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF