Bug report #19472

v.surf.rst NOT WORKING IN QGIS 3.2.0 BONN

Added by Marco Ugalde over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:Alexander Bruy
Category:Processing/GRASS
Affected QGIS version:3.4.3 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27300

Description

Good afternoon. I always use v.surf.rst in Qgis 2.16 and 2.18 to interpolate points using a raster as a mask, but it is not working in QGIS 3.2.0. I got an error message in red (see attached file). I use the default parameters.

v.sur.rst.txt Magnifier (1.08 KB) Marco Ugalde, 2018-07-23 06:56 PM

Processing algorithm.txt Magnifier - Whole log error (10 KB) Marco Ugalde, 2018-07-24 05:55 PM

v.surf.rst.txt Magnifier (2.72 KB) Pedro Venâncio, 2019-01-10 01:06 PM

v.surf.rst.cvdev.txt Magnifier (2.12 KB) Pedro Venâncio, 2019-01-10 01:07 PM

Associated revisions

Revision 34ec1833
Added by Alexander Bruy about 1 year ago

[processing] split v.surf.rst algorithm into two (fix #19472)

This algorithm cannot output cross-validation results and topographic
parameters simultaneously, hence two tools needed. Thanks to Pedro Venâncio
for finding this and proposing a fix.

Revision c2465fc4
Added by Alexander Bruy about 1 year ago

[processing] split v.surf.rst algorithm into two (fix #19472)

This algorithm cannot output cross-validation results and topographic
parameters simultaneously, hence two tools needed. Thanks to Pedro Venâncio
for finding this and proposing a fix.

(cherry picked from commit 34ec183354ba709c2b848395d77710b1c349e7b5)

History

#1 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Feedback

Please post the full contents of the log window

#3 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Open

There is a problem with paths to GRASS executables:

"C:\PROGRA~1\QGIS" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
"C:\PROGRA~1\QGIS" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
"""" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
Presione una tecla para continuar . . . 
"C:\PROGRA~1\QGIS" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
"C:\PROGRA~1\QGIS" no se reconoce como un comando interno o externo,

In the meantime use QGIS LTR (2.18), is safer at this stage (for Processing tools).

#4 Updated by Marco Ugalde over 1 year ago

Thank you!

#5 Updated by Giovanni Manghi over 1 year ago

  • Regression? changed from No to Yes
  • Category changed from GRASS to Processing/GRASS
  • Priority changed from Normal to High

#6 Updated by Rayne Harold over 1 year ago

-

#7 Updated by Nyall Dawson about 1 year ago

  • Status changed from Open to Feedback

Is this still an issue in 3.4?

#8 Updated by Paolo Cavallini about 1 year ago

Confirmed in 3.4.2

#9 Updated by Paolo Cavallini about 1 year ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 3.2 to 3.4.2

#10 Updated by Paolo Cavallini about 1 year ago

  • Affected QGIS version changed from 3.4.2 to 3.4.3

#11 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Nyall Dawson wrote:

Is this still an issue in 3.4?

it works OK here in 3.4.3 on Ubuntu (but not using a temp point layer).

#12 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Feedback to Open

Giovanni Manghi wrote:

Nyall Dawson wrote:

Is this still an issue in 3.4?

it works OK here in 3.4.3 on Ubuntu (but not using a temp point layer).

no, is not working, my mistake.

#13 Updated by Pedro Venâncio about 1 year ago

The problem with v.surf.rst in QGIS 3.x.x is because it is trying to output the cross-validation result and the topographic parameters at the same time, and this is not possible.

So, the approach needs to be the same as in QGIS 2.x.x, by separating v.surf.rst in two different processing modules (v.surf.rst and v.surf.rst.cvdev).

I attach the description files with this approach. I can make a pull request with this update, but if someone can do it quicker (Nyall? Giovanni?), I appreciate that, because at this moment I don't have access to my dev machine. And this needs to be backported to QGIS 3.4.x.

Thanks!

#14 Updated by Giovanni Manghi about 1 year ago

  • Assignee set to Giovanni Manghi

Pedro Venâncio wrote:

The problem with v.surf.rst in QGIS 3.x.x is because it is trying to output the cross-validation result and the topographic parameters at the same time, and this is not possible.

So, the approach needs to be the same as in QGIS 2.x.x, by separating v.surf.rst in two different processing modules (v.surf.rst and v.surf.rst.cvdev).

I attach the description files with this approach. I can make a pull request with this update, but if someone can do it quicker (Nyall? Giovanni?), I appreciate that, because at this moment I don't have access to my dev machine. And this needs to be backported to QGIS 3.4.x.

Thanks!

thanks Pedro for catching this. I'll try create a PR today.

#15 Updated by Alexander Bruy about 1 year ago

  • Operating System deleted (Windows 10)
  • Status changed from Open to In Progress
  • Assignee changed from Giovanni Manghi to Alexander Bruy

#16 Updated by Alexander Bruy about 1 year ago

  • Pull Request or Patch supplied changed from No to Yes

#17 Updated by Alexander Bruy about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#18 Updated by Alexander Bruy about 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF