Bug report #19351

[processing] Wrong management of locale in output result path

Added by Luigi Pirelli about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:3.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27179

Description

I'm writing a report for a strudent. This is the running context.

System Lcale: es_ES
QGIS Locale: system (but also Ignore System + setting QGIS locale to es_ES)

open SAGA "reclassify values" (but it shouldn't depend on the algorithm)
set output to a laayer in a path with some "strange" chararacter as ñ è etc etc

the run is ok, but fail loading back the result that is not created


Related issues

Duplicates QGIS Application - Bug report #18617: QGIS3: SagaUtils.py fails when comman contains non-latin ... Closed 2018-04-03

Associated revisions

Revision 76d9ab82
Added by Victor Olaya over 1 year ago

[processing] fixed SAGA for non-ascii output files

Fixes #19351

History

#1 Updated by Luigi Pirelli about 2 years ago

assigned to @elpaso because could be related with locale management. Feel free to reassign to @alexbruy or @nyalldawson if it's more related to processing

#2 Updated by Alessandro Pasotti about 2 years ago

  • Assignee deleted (Alessandro Pasotti)

I don't think it's related to locale management. Does it work on 3.0 ?

#3 Updated by Luigi Pirelli about 2 years ago

  • Assignee set to Alessandro Pasotti

I'll check... now reinstalling everitying because my system is broken... so I'll test as soon as I can

#4 Updated by Nyall Dawson about 2 years ago

I think this is actually a limitation in saga itself. Try a native algorithm.

#5 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

In other words - can you please try the same algorithm directly from the saga command line, using the same paths, and see what happens

#6 Updated by Giovanni Manghi about 2 years ago

is this about output names, or (vector table) output content?

#7 Updated by Luigi Pirelli about 2 years ago

outptuth path of the result not the content (AFAIK)

#8 Updated by Luigi Pirelli about 2 years ago

  • Subject changed from [processing] Wrong management of locale in output results to [processing] Wrong management of locale in output result path

#9 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee deleted (Alessandro Pasotti)

#10 Updated by Alexander Bruy over 1 year ago

Probably duplicates #18617

#11 Updated by Alexander Bruy over 1 year ago

  • Duplicates Bug report #18617: QGIS3: SagaUtils.py fails when comman contains non-latin characters added

#12 Updated by Victor Olaya over 1 year ago

It's not a duplicate. #18617 is a problem creating the script files. Here the issue is a SAGA one, which doesnt support non-ascii for outputs. If a file like "ñoño.shp" is entered as output, SAGA will save it to "±o±o.shp". The file is created, but Processing cannot find it later.

The solution should be something saving to a different filename (safe, without non-ascii) and later renaming it.

I will work on that.

#13 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Open

#14 Updated by Luigi Pirelli over 1 year ago

  • Assignee set to Victor Olaya

#15 Updated by Victor Olaya over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF