Bug report #19292

Text annotation boxes too small in print or pdf

Added by Morten Storm over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.2 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27120

Description

When printing or creating PDFs with a map layout containing a text annotation box, the text annotation is printed way smaller than on screen.

This does not happen in QGIS 2.18. Attached are two PDFs created from the same project in 2.18 and 3.2 respectively.

test2_18.pdf - PDF created in QGIS 2.18 (1.12 MB) Morten Storm, 2018-06-28 09:38 AM

test3_2.pdf - PDF created in QGIS 3.2 (1.13 MB) Morten Storm, 2018-06-28 09:39 AM

annotations.jpg (290 KB) Dmitry Kravchook, 2018-08-23 05:47 PM

History

#1 Updated by Dmitry Kravchook over 2 years ago

I confirm that.

QGIS version
3.2.2-Bonn
QGIS code revision
26842169e9

Linux and Windows same thing.

#2 Updated by Giovanni Manghi over 2 years ago

  • Regression? changed from No to Yes
  • Operating System deleted (Windows 7)
  • Priority changed from Normal to High

#3 Updated by Morten Storm about 2 years ago

An additional observation:

If you change the blending mode of your map item (under Item Properties > Rendering) from 'Normal' to 'Darken' or 'Multiply', text annotation boxes are printed with the right size! :-)

#4 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #18373

Also available in: Atom PDF