Bug report #18398

QGIS3 Print settings error

Added by Noel Ballantyne about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.0.0 Regression?:Yes
Operating System:win 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26288

Description

I'm new here. I have searched but haven't found this error over the past few days.

I updated from 2.18 to 3. Opened an existing project, everything great, faster rendering (yay).

When printing directly to the A4 printer, the paper size is not recognised by the printer and when the layout does print, part of the layout is missing. I have tried to print to A0 printer and the paper size keeps changing to A4 from A0 or A1

When I print to pdf, everything is fine.

planners areas 2017.dbf (10.6 KB) Noel Ballantyne, 2018-03-12 05:04 PM

planners areas 2017.cpg (5 Bytes) Noel Ballantyne, 2018-03-12 05:04 PM

planners areas 2017.prj (411 Bytes) Noel Ballantyne, 2018-03-12 05:04 PM

planners areas 2017.qpj (648 Bytes) Noel Ballantyne, 2018-03-12 05:04 PM

planners areas 2017.shx (172 Bytes) Noel Ballantyne, 2018-03-12 05:04 PM

planners areas 2017.shp (1.05 MB) Noel Ballantyne, 2018-03-12 05:04 PM

Japanese_Knotweed.prj (400 Bytes) Noel Ballantyne, 2018-03-12 05:06 PM

Japanese_Knotweed.sbn (1.18 KB) Noel Ballantyne, 2018-03-12 05:06 PM

Japanese_Knotweed.sbx (188 Bytes) Noel Ballantyne, 2018-03-12 05:06 PM

Planning Register 3.0 sample.qgs (279 KB) Noel Ballantyne, 2018-03-12 05:07 PM

Associated revisions

Revision a87a7b72
Added by Nyall Dawson almost 2 years ago

[layouts] Attempted fix for direct printing page orientation issues

Seems the earlier hack may no longer be valid for Qt5.

Fixes #18398, #18994, #19142, #19279

Revision 44332c14
Added by Nyall Dawson almost 2 years ago

[layouts] Attempted fix for direct printing page orientation issues

Seems the earlier hack may no longer be valid for Qt5.

Fixes #18398, #18994, #19142, #19279

(cherry-picked from a87a7b72d)

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

worked ok on 2.18?

#2 Updated by Noel Ballantyne about 2 years ago

Giovanni Manghi wrote:

worked ok on 2.18?

Yes all layouts printed ok on 2.18

#3 Updated by Alessandro Pasotti about 2 years ago

can you attach your test project (and minimal data)?

#4 Updated by Noel Ballantyne about 2 years ago

690 layers in file.

Ill trim in down to 3/4,

Will i do same for 2.18 version?

#6 Updated by Alessandro Pasotti about 2 years ago

Thanks, no need to attach a 2.x project: the layout code is a complete rewrite.

#7 Updated by Fernando Ciges about 2 years ago

The same happens to me. I have gone from version 2.18 to version 3.0. In the Las Palmas version I had no problem with printing.
I usually work in A3 format and as I said in version 2.18 I did not have any problems with printing from the "designer manager", but in version 3.0, from the "Show Layout" I printed the rotated drawing occupying only a part of A3 paper. Paper comes out horizontally and printing makes it vertical. It is not a problem to configure the printer or the preferences because with version 2.18 I do exactly the same and print well.

#8 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Also available in: Atom PDF