Bug report #18213

Processing modeler - undocked panes should be closed when the modeler is closed

Added by Alister Hood over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Low
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:3.1(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26104

Description

If you undock the "inputs" pane (etc) it will stay open when you close the modeller.
After that, things can get weird, although I haven't tested thoroughly enough to detail exactly what happens in what situations (perhaps it is partly operating system dependent - I tested briefly on Windows and with a slightly old nightly on Ubuntu under WSL):
- you can't close the floating panes (need to redock them and then restart qgis if there was more than one copy of one - see below).
- if you reopen the modeller you might be able to use the floating pane that is already open (or more likely I was just tricked by a new copy of the floating pane opening above an old one), but
- you might get another instance of the floating pane, in which case you can't use the first instance. The first instance will also stay open even if you dock the second one.

Associated revisions

Revision bfa3cab0
Added by Nyall Dawson over 2 years ago

[processing] Fix model docks are not removed when closing modeler

Actually caused by the modeler dialog never being deleted correctly.

Fixes #18213

History

#1 Updated by Alister Hood over 2 years ago

  • Affected QGIS version changed from 3.0.0 to 3.1(master)

Sorry, the main testing was on the latest osgeo4w64 nightly.
Although since a pre-3.0.0-release ubuntu nightly is also affected I presume 3.0.0 is too...

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to In Progress

#3 Updated by Alexander Bruy over 2 years ago

Probably duplicates #18189

#4 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#5 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF