Bug report #18194

QGIS3 Processing Graphical Modeler GUI is messed up on OSX

Added by asgerpetersen - over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:3.0.0 Regression?:Yes
Operating System:OSX High Sierra Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26085

Description

The GUI for the graphical modeller is so messed up on OSX that it is not usable. Please see the attached screenshot.

My version of QGIS is compiled using https://github.com/qgis/homebrew-qgisdev.

Latest commit is 70c68df72a which is a few minutes after branching off QGIS 3.0.

Also see attached screen dump of "About QGIS" for Qt versions etc.

Other parts of this QGIS build seem to work as expected.

2018-02-23_15-11-08.png - Screen dump of Graphical Modeller (40.3 KB) asgerpetersen -, 2018-02-23 03:15 PM

2018-02-23_15-13-16.png - About QGIS (86.2 KB) asgerpetersen -, 2018-02-23 03:15 PM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This is fixed in the code, but you'll need to manually uninstall the qgis qt custom widgets.

#2 Updated by Alister Hood over 2 years ago

Translation based on #18065: "delete qgis_customwidgets.py"

#3 Updated by Jürgen Fischer over 2 years ago

  • Description updated (diff)

#4 Updated by Daniel Victoria over 2 years ago

I'm seeing that this issue is closed. But I'm having the same problem in QGIS 3.0.0 - Girona, running on Ubuntu 16.04 installed from the http://qgis.org/ubuntugis repository. Any idea when the fix will make it to the debian / ubuntu packages in the repository?

Also available in: Atom PDF