Bug report #18090

[Metadata] Allow to remove categories in Layer properties --> Metadata

Added by Harrissou Santanna almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Metadata
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25986

Description

Layer Properties dialog --> Metadata --> Categories tab
The dialog allows you to add new categories but there's no way to remove unwanted categories.
I don't know if it should allow to remove predefined categories but at least the ones I created should be erasable.

Associated revisions

Revision cd24adbf
Added by Nyall Dawson almost 3 years ago

[needs-docs] Rework arrangement of buttons in categories tab in
metadata editor to make their operation more self-explanatory
for users.

Also add tooltips to the buttons describing their function, and
allow the buttons to operate on multiple selected rows at once.

Fixes #18090

History

#1 Updated by Etienne Trimaille almost 3 years ago

The left arrow will remove the selected category from the right panel:
  • If it's a predefined one, it will come back to the left panel
  • If it's not, it will be removed.

I don't know if it should allow to remove predefined categories

I don't understand, you can already do it. The left panel is only showing some default ones. These categories are not included in your metadata.

So you would like the red minus icon?

#2 Updated by Harrissou Santanna almost 3 years ago

Yes I was expecting a minus button and as i did not find any, I never tried to add a new category because I was afraid i'd "corrupt" my data (this is not an area i use so no need to take a risk :) ).
I just give it a test now. I thought new category would be added to the left panel, growing the list and then stored in some custom setting for further reuse.
Hummm btw the behavior of this dialog is quite different from what QGIS often offers in this kind of configuration.
Anyway, i have no strong opinion on the design here. Feel free to ignore/close this issue report.
And Thanks for the explanation.

#3 Updated by Nyall Dawson almost 3 years ago

  • Pull Request or Patch supplied changed from No to Yes

#4 Updated by Nyall Dawson almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF