Bug report #17918

Rule-based labelling: Rules not sortable

Added by Bernd Vogelgesang over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Labelling
Affected QGIS version:master Regression?:Yes
Operating System:Linux Mint 18.2 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25814

Description

I have a graduated layer style and would like to switch this to rule-based for usage in the atlas.
When I add a new rule, which should represent the parent rule of the already existing ones from the graduated style, it is positioned below the current rule.
I fail to drag it above, or drag those other rules below it, forming a rule tree.
The mouse gets stuck and I can only go on by hitting ESC

As there are no buttons for up/down, indent/outdent, the process fully relies on mouse actions, which unfortuanetly fail at my maschine.

History

#1 Updated by Alessandro Pasotti over 2 years ago

  • Assignee set to Alessandro Pasotti
  • Status changed from Open to Feedback

A short video would probably help here, I tried to replicate the bug following your description but I didn't succeed: I was able to switch from categorized to rule-based, create a new rule and drag-drop the other rules below it to form a tree.

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Feedback to Closed

Closing due to lack of feedback

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable

Also available in: Atom PDF