Bug report #17226

Geopackage "Select Vector Layers to Add" dialogue has wrong nr of features

Added by Andreas Neumann almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Even Rouault
Category:GUI
Affected QGIS version:master Regression?:Yes
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25125

Description

If one drags and drops a geopackage into QGIS master, the column labeled "Number of features" in the "Select Vector Layers to Add" dialogue is always listing zero.

Instead the number of features seem to be listed in the "Layer name" column, separated by a colon. See screenshot attached.

In 2.18.x this still worked fine - so seems to be a regression.

gpkg_drag_and_drop_dialogue_issue.png (70.5 KB) Andreas Neumann, 2017-10-02 12:40 PM


Related issues

Duplicates QGIS Application - Bug report #17222: OpenFileGDB feature count showing in layer name value Closed 2017-09-29

History

#1 Updated by Andreas Neumann almost 3 years ago

screenshot demonstrating the issue.

#2 Updated by Andreas Neumann almost 3 years ago

Same issue appears on Linux

#3 Updated by Even Rouault almost 3 years ago

  • Assignee set to Even Rouault

#4 Updated by Giovanni Manghi almost 3 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High

#5 Updated by Even Rouault almost 3 years ago

  • Status changed from Open to Feedback

Can you retry ? I can't reproduce this . I belive this has been fixed and is a duplicate of #17222

#6 Updated by Jürgen Fischer almost 3 years ago

  • Duplicates Bug report #17222: OpenFileGDB feature count showing in layer name value added

#7 Updated by Andreas Neumann almost 3 years ago

  • Resolution set to fixed/implemented

Seems to be fixed now.

#8 Updated by Andreas Neumann almost 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF