Bug report #16914

Line dash pattern symbol gets displaced along line when feature crosses canvas border

Added by Nikolay Lebedev over 3 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.18.10 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24813

Description

When setting a dash pattern symbol the pattern gets uncontrollable when feature crosses canvas border.
I suppose it gets rendered starting from a visible part of the feature.
Setting dash size in map units doesn't affect positioning.
Setting "Avoid artifacts when project is rendered as map tiles" doesn't help, though this is the expected behaviour.
So there is no precise control of what feature looks like, i.e. dashes move away from feature corners.
This video demonstrates the issue.

line_pattern_bug.mov (2.81 MB) Nikolay Lebedev, 2017-07-24 12:06 PM

x11grab.mp4 (126 KB) Johannes Kroeger, 2018-09-01 05:54 PM

History

#1 Updated by Nikolay Lebedev over 3 years ago

Attached video if YouTube isn't availiable.

#2 Updated by Johannes Kroeger about 2 years ago

Yes, this is due to the geometries being clipped off at the edges of the canvas.

I wonder if it would be possible to store the length of the clipped-off part to add an offset to the lines' starting point.

#3 Updated by Johannes Kroeger about 2 years ago

Quoting Nyall Dawson from https://issues.qgis.org/issues/16051:

This is caused by the automatic clipping of geometries to the canvas extent (+ a small buffer). You can prevent this by clicking the advanced button in the symbol properties window, and uncheck "clip features to canvas extent".

This issue can be closed.

#4 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to invalid

Also available in: Atom PDF