Bug report #16051

Gradient fills get offset on high zoom

Added by Johannes Kroeger over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:23966

Description

I made a bunch of hexagons and filled them with a Gradient Fill. The Coord mode is "object". If I zoom in, I get offset gradients in the objects that intersect the map canvas edges. There the gradient fills are not centered on the centroid of the object. This happens both when Reference Point 1 is set to Centroid or something else.

Attached are some screenshots. Look at the left side and see how the gradients are misplaced.

QGIS version 2.99.0-Master, QGIS code revision 7b17751f71 (a couple of days ago).

qgis_centroid_gradient_linear.jpg (118 KB) Johannes Kroeger, 2017-01-09 08:32 AM

qgis_centroid_gradient_conical.jpg (137 KB) Johannes Kroeger, 2017-01-09 08:32 AM

qgis_centroid_gradient_radial.jpg (128 KB) Johannes Kroeger, 2017-01-09 08:32 AM

History

#1 Updated by Nyall Dawson over 3 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This is caused by the automatic clipping of geometries to the canvas extent (+ a small buffer). You can prevent this by clicking the advanced button in the symbol properties window, and uncheck "clip features to canvas extent".

Also available in: Atom PDF