Bug report #16874

Error "Could not create transform to calculate true north" when a north arrow decoration displayed in the map editor

Added by Patrick Dunford about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Alexander Bruy
Category:Decorations
Affected QGIS version:master Regression?:Yes
Operating System:Xubuntu artful Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24773

Description

Build b350676


Related issues

Duplicated by QGIS Application - Bug report #17108: Project with CRS set to 'No projection (or unknown/non-Ea... Closed 2017-09-06

Associated revisions

Revision 19b1b799
Added by Alexander Bruy almost 3 years ago

prevent crash from north arrow if project CRS is not defined (fix #16874)

History

#1 Updated by Patrick Dunford about 3 years ago

Probably due to the missing CRS in the project file

#2 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

what is the "map editor", the print composer?

possibly related to #16873

#3 Updated by Nyall Dawson about 3 years ago

I suspect it means map canvas (i.e. North arrow decoration)

#4 Updated by Giovanni Manghi about 3 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Status changed from Feedback to Open
  • Category changed from GUI to Decorations

Raising priority assuming is the map canvas.

#5 Updated by Alexander Bruy almost 3 years ago

  • Duplicated by Bug report #17108: Project with CRS set to 'No projection (or unknown/non-Earth projection)' throws exception with North Arrow added

#6 Updated by Alexander Bruy almost 3 years ago

  • Assignee set to Alexander Bruy
  • Status changed from Open to In Progress

#7 Updated by Alexander Bruy almost 3 years ago

  • Pull Request or Patch supplied changed from No to Yes

#8 Updated by Alexander Bruy almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF