Bug report #16873

7d67b02 changes or corrupts project format without warning (from 313ec55)

Added by Patrick Dunford about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:master Regression?:Yes
Operating System:Xubuntu artful Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24772

Description

If I open a project in 7d67b02 then save it then try to reopen it in 313ec55 some data can't be read.
Examples include the project CRS, and layer labels.

There are no warnings on opening the project in 7d67b02 that the project file format has changed, which would ordinarily be the case.

History

#1 Updated by Patrick Dunford about 3 years ago

It looks like in 7d67b02 it has trouble recognising the CRS because it's displaying in project properties "No projection or unknown/non-earth projection"

#2 Updated by Giovanni Manghi about 3 years ago

  • Crashes QGIS or corrupts data changed from Yes to No

#3 Updated by Patrick Dunford about 3 years ago

This has been confirmed as an issue in Windows 7 x64 with build c1d339c

I disagree that you have changed the status of "Corrupts data" to No because there is significant data not being displayed on the map, indicating the project file is probably corrupted.

#4 Updated by Giovanni Manghi about 3 years ago

Patrick Dunford wrote:

This has been confirmed as an issue in Windows 7 x64 with build c1d339c

indicating the project file is probably corrupted.

have you checked? project files are xml that you can compare easily.

#5 Updated by Giovanni Manghi about 3 years ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

Patrick Dunford wrote:

This has been confirmed as an issue in Windows 7 x64 with build c1d339c

I disagree that you have changed the status of "Corrupts data" to No because there is significant data not being displayed on the map, indicating the project file is probably corrupted.

I also think that with the amount of work and changes being done on qgis master this should be probably be spotted and fixed soon.

#6 Updated by Patrick Dunford about 3 years ago

Sample data:
https://drive.google.com/open?id=0ByH1cL0SIi1vWkQ0cFR4NVBGc3c

Confirmed as an issue with Linux build 7d67b02 and later, Windows build c1d339c

Download the folder "Qgis Sample"
Start Qgis and click to open a project
Open the QGis Sample folder
Open the GD folder
Open the RM folder
Open the Project folder
Open the OS folder
Open the project file "OtagoSouthland299c.qgs"
There should be a message about 97 missing layers, this can be ignored (click OK)
As the project opens you will see "Exception" Could not create transform to calculate true north
The reason for this error is the project CRS has not been recognised. Click on Project Properties then you can see "No projection (or unknown / non earth projection)" is checked. (The project was created with the EPSG:3857 projection)

Familiarise yourself with the range of layers being displayed in the map.
Save the project under a new name.
Close Qgis (or click the New button to close the current project)
Start Qgis (or re open the project)
Notice how many layers are not now displayed. In particular:
All of the "Global Water" layers
All of the "Land" layers
All of the "Terrain" layers.
All layer labels have disappeared.

#7 Updated by Jürgen Fischer about 3 years ago

  • Description updated (diff)

#8 Updated by Patrick Dunford about 3 years ago

And this is a still a problem in the latest master 655f121

#9 Updated by Nyall Dawson about 3 years ago

  • Status changed from Open to Feedback

Are you loading a project from an earlier 3.0 build, or a stable 2.x build?

#10 Updated by Patrick Dunford about 3 years ago

It's several projects I have been working with in 2.99 through various builds throughout the past year or so. They have been updated numerous times with new masters changing formats. However the masters I use most frequently (stable enough to be used all the time for production projects) are 313ec55 on Xubuntu 16.04/17.04 and 1182816 on Windows 7.

#11 Updated by Nyall Dawson about 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

In that case there's no issue here - we don't gaurantee project stability during a development release (since it adds extra code we have to stay around forever more). If this was a 2.x project, then it's a different story.

#12 Updated by Patrick Dunford about 3 years ago

Nyall Dawson wrote:

In that case there's no issue here - we don't gaurantee project stability during a development release (since it adds extra code we have to stay around forever more). If this was a 2.x project, then it's a different story.

The expected behaviour in all other versions of the software is a warning message telling you that the project format has changed.

#13 Updated by Patrick Dunford about 3 years ago

Two questions:

1. Either the software intentionally upgrades the project file format without issuing a warning, or
2. The software contains a bug that causes the project file format to become corrupted.

I don't think this response has resolved either of those questions.

Also available in: Atom PDF