Bug report #16715

Processing: SELECT algs don't work in modeller on Windows

Added by jd lom over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Alexander Bruy
Category:Processing/Modeller
Affected QGIS version:2.18.9 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24614

Description

Hi,

this bug only exists on windows. Select algs ( select by expression, select by location...) work well on linux qgis 2.18.9.
I have tested for the moment only on 2.18.9 on windows (x64) et linux (x86) (not mac). I will test on master (windows) too.

The select algs seems to work well on every system when the selection is not made on the output of a geoprocessing alg.

I made some model to reproduce the bug and there is a video.
All models work perfectly well on linux.

Only tested with select by expression and select by location.

Maybe related to this #14645

Regards,

bug-select.zip (1.53 MB) jd lom, 2017-06-15 10:35 PM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Operating System changed from WINDOWS to Windows
  • Subject changed from On windows : SELECT algs in modeler don't work to Processing: SELECT algs don't work in modeller on Windows
  • Priority changed from High to Normal

#2 Updated by Anita Graser over 3 years ago

Since models in current Processing versions ignore selections, I'm not sure if there is any use case for the select tools inside models.

#3 Updated by jd lom about 3 years ago

Anita Graser wrote:

Since models in current Processing versions ignore selections, I'm not sure if there is any use case for the select tools inside models.

So what the point to have 'save selected features' algorithm ?

#4 Updated by Nyall Dawson about 3 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Fixed in master

#5 Updated by Jürgen Fischer about 3 years ago

  • Description updated (diff)

Also available in: Atom PDF