Bug report #16427

WMTS rendering problems in 2.18 and Master

Added by Tudor Bărăscu over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Web Services clients/WMS
Affected QGIS version:2.18.11 Regression?:Yes
Operating System:Debian Stretch Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24336

Description

I've encountered WMTS rendering problems on Master 61137dc8bf7bc7d8a5e7401442e2af6bd88c19e0 .
Basically, I often don't see any rendered image.
On 2.18.6 and 2.14.13 it works flawlessly.

How to replicate:

Add any layer (e.g. Ortofoto2015) from https://gis.apavil.ro/cache/ortofoto/wmts/1.0.0/WMTSCapabilities.xml (user: qgis password qgis )
Panning and zooming in/out will immediately show the issue.


Related issues

Related to QGIS Application - Bug report #16267: Printing Pdf's that have WMTS layers problems Closed 2017-03-02

Associated revisions

Revision d102404b
Added by Alessandro Pasotti about 2 years ago

[bugfix] Do not cache invalid WMS responses

The problem here was that in case of http->https redirect
from a misconfigured server (that advertizes http and then
redirects all request to https) all http redirect requests
were cached, making all subsequent requests to the same
url hit the 301 Moved Permanently reponse page intead of
the redirected content.

Fixes #16427 WMTS rendering problems in 2.18 and Master

Revision b09fb37d
Added by Alessandro Pasotti about 2 years ago

[bugfix] Do not cache invalid WMS responses

The problem here was that in case of http->https redirect
from a misconfigured server (that advertizes http and then
redirects all request to https) all http redirect requests
were cached, making all subsequent requests to the same
url hit the 301 Moved Permanently reponse page intead of
the redirected content.

Fixes #16427 WMTS rendering problems in 2.18 and Master

cherry-picked from d102404b5e6796727c0ae0c983cf016ab33ff27a

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Tudor Bărăscu over 2 years ago

Actually I can replicate also under 2.18.7. It doesn't pop up as often as in master though.
If I add the of2015 layer and go to 1:3018 scale and pan, the issue pops up.

See also #16267

#3 Updated by Jürgen Fischer over 2 years ago

#4 Updated by Tudor Bărăscu over 2 years ago

Still present in 2.18.10 and Master.

At least for 2.18, the bug appears at my screens max resolution: 2560x1600 (Macbook Pro 13.3)
For a lower resolution (1920x1200) I cannot replicate.

#5 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback
  • Description updated (diff)

Tudor Bărăscu wrote:

Still present in 2.18.10 and Master.

At least for 2.18, the bug appears at my screens max resolution: 2560x1600 (Macbook Pro 13.3)
For a lower resolution (1920x1200) I cannot replicate.

Hi Tudor!
it is a regression, correct? On On 2.18.6 and 2.14.13 it worked also at 2560x1600?

#6 Updated by Tudor Bărăscu over 2 years ago

For 2.14 it works flawlessly. Only Master and 2.18 are affected.

For 2.18 the problem started with the f5b657db19eda7e72e6ed34eb7fe333c156acad0.

Yes, it's a regression.

#7 Updated by Giovanni Manghi over 2 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Affected QGIS version changed from master to 2.18.10
  • Status changed from Feedback to Open

#8 Updated by Giovanni Manghi over 2 years ago

  • Subject changed from WMTS rendering problems in Master to WMTS rendering problems in 2.18 and Master

#9 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11

#10 Updated by Alessandro Pasotti about 2 years ago

  • Assignee set to Alessandro Pasotti

#11 Updated by Alessandro Pasotti about 2 years ago

@Tudor: just to remove one possible cause, would you be able to test this by temporarily disabling HTTPS?
The getcapabilities returns plain http addresses and all request gets redirected to https, I'm observing wierd caching issues and I'd like to confirm that this might be the cause of this issue.

#12 Updated by Alessandro Pasotti about 2 years ago

  • Pull Request or Patch supplied changed from No to Yes

For master: https://github.com/qgis/QGIS/pull/5289
Needs backporting to 2.18

#13 Updated by Anonymous about 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#14 Updated by Tudor Bărăscu about 2 years ago

@Alessandro I could have swore that the GetCapabilities were returning the https part and that I had fixed this issue last year.

I have created http://mp.qtibia.ro/ortofoto/wmts/1.0.0/WMTSCapabilities.xml pointing to the same mapproxy server working on http and https but without redirect so you can test.

#15 Updated by Alessandro Pasotti about 2 years ago

Thanks, but I think it's fixed, I still need to backport it to 2.18.

#16 Updated by Tudor Bărăscu about 2 years ago

Thanks a lot for your work Alessandro!

#17 Updated by Jürgen Fischer about 2 years ago

  • Description updated (diff)

Also available in: Atom PDF