Bug report #16267

Printing Pdf's that have WMTS layers problems

Added by Tudor Bărăscu over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24177

Description

Hello,

In 2.18.4, 2.14.12 projects that have a WMTS layers I've noticed the resulted pdf image is randomly missing tiles.
I tested on Debian stretch and on Windows.
This does not happen on Master.

I've attached a project with a composer pointing to https://gis.apavil.ro/cache/ortofoto/wmts/1.0.0/WMTSCapabilities.xml with user and password qgis .

How to replicate:
- Either open the attached project and print the existing "test" composer or:

- Add a layer (Ortofoto2015) from https://gis.apavil.ro/cache/ortofoto/wmts/1.0.0/WMTSCapabilities.xml (user: qgis password qgis)
- Create a new composer (A0 does it) at scale 1:2000
- Print Pdf

Thank you!

problem.png (323 KB) Tudor Bărăscu, 2017-03-02 10:21 PM

print.qgs - test project (2.14.12) (7.72 KB) Tudor Bărăscu, 2017-03-02 10:21 PM

test_WMTS.png (1.02 MB) Nino Formica, 2018-03-02 09:37 PM


Related issues

Related to QGIS Application - Bug report #16427: WMTS rendering problems in 2.18 and Master Closed 2017-04-08

History

#1 Updated by Giovanni Manghi over 2 years ago

I can see it also here. 2.18.4 too on Linux.

#2 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Jürgen Fischer over 2 years ago

#4 Updated by Nino Formica over 1 year ago

I tested with QGIS 2.18.17 (Ubuntu 16.04) using a layer WMTS from http://webgis.arpa.piemonte.it/ags101free/rest/services/topografia_dati_di_base/Ortofoto_risknat_WM_Compact/MapServer/WMTS/.

Then I created a print composer A0 format (scale 1:2000) and I have exported it as PDF: no problem, layer is printed in full (all tiles).
I cannot attach it (file PDF) because too big, so I attach an image.

#5 Updated by Paolo Cavallini over 1 year ago

  • Resolution set to fixed/implemented
  • Description updated (diff)
  • Status changed from Open to Closed

Also available in: Atom PDF