Bug report #1589

problem visualizing WMS defined with a EPSG:NONE srs

Added by francesco - about 11 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:11649

Description

Hello all !

We have small problem, with our WMS service and qGis.

We expose some data in WMS, but we have a customized reference system,
so we don't have a standard EPSG number.
We expose, then, these data with the "EPSG: NONE" declaration.

We are aware that the OGC directive on the WMS 1.1.1 defines only the
declaration "SRS=NONE", but in the Esri products (WMS server and
client) define the SRS="EPSG:NONE" declaration (for the 9.2 version)
and SRS="EPSG:0" for the 9.3 version.

For example, if I call a WMS with this layer definition in his
Capabilities file:

<Layer queryable="0">
<Name>158_UTMA_ORTOAGEA2008</Name>
<Title>158_UTMA_ORTOAGEA2008</Title>
<SRS>EPSG:NONE</SRS>
<LatLonBoundingBox minx="9.1600714390999993" miny="43.672498615800002"
maxx="12.9109804049" maxy="45.156071086600001" />
<BoundingBox SRS="EPSG:NONE" minx="512973.566244238" miny="842599.75"
maxx="807851.62554267596" maxy="1000499.3733534738" />
<Abstract>158_UTMA_ORTOAGEA2008 (Cellsize=0.5, BitsPerPixel=8)</Abstract>
</Layer>

then qGis calls this layer with this request:

?REQUEST=GetMap&SERVICE=WMS&VERSION=1.1.1&LAYERS=158_UTMA_ORTOAGEA2008&STYLES=&BGCOLOR=0xFFFFFF&TRANSPARENT=TRUE&SRS=CRS:84&BBOX=9.1600714390999993,43.672498615800002,12.9109804049,45.156071086600001&FORMAT=image/jpeg&WIDTH=640&HEIGHT=373

It seems that qGis is not recognizing the EPSG:NONE, while with others
WMS clients (ArcMap, Gaia, uDig, GvSig) this layer is requested
calling the EPSG:NONE and it is visualized correctly.

Would be nice that also qGis keeps the SRS definition in the
Capabilities file and calls the request GetMap with that SRS.

Thanks,
francesco

History

#1 Updated by Giovanni Manghi over 10 years ago

Hi,

what is the status of this ticket? still a issue with the latest versions of qgis?

Do you have a public url that can be used to make further tests?

#2 Updated by Paolo Cavallini almost 10 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Closing it because of lack of user feedback. Please reopen if appropriate (especially if you can provide a sample WMS)

#3 Updated by Jürgen Fischer over 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (invalid)

see also #3156

#4 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Giovanni Manghi over 7 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)
  • Operating System deleted (All)
  • Status info deleted (0)

#8 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#9 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

seems the same issue as #4946

Also available in: Atom PDF