Bug report #3156

wms getmap request with unknown epsg

Added by francesco - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13216

Description

Hello all,
we noticed that qgis in not able to build the WMS getMap Request if an EPSG is not recognized by qgis (meaning that it is not in the tbl_srs table of the srs.db database).
since the 1.5 version we can easily add the unknown epsg just adding a record in that table, but you can understand that in not nice to have to maintain that table manually. For example, in that DB it is not present the EPSG:102113, that is the Web Mercator (Google) for Esri. Just adding the record in the tbl_srs table then qgis is able to build the correct getMap request, including the SRS parameter with the EPSG chosen by the user. Otherwise it include the CRS:84.
What we can not understand is why for qgis it is not enough to read the SRS from the capabilities file and let the user to choose the EPSG even when the EPSG is not in the tbl_srs table.
We have this problem mainly with our customized SRS that is an UTM ED50 with a false northing of -4000000, so we have a WMS with the EPSG:NONE or EPSG:0, but for correct add the WMS layer in qgis we had to add a record in the tbl_srs (with this prj: "+proj=tmerc +lat_0=0 +lon_0=9 +k=0.9996 +x_0=500000 +y_0=-4000000 +ellps=intl +units=m +no_defs") and it works. In this case we have to send the customized srs.db to the user that wish to visualize our WMS in qgis: really not nice.
For example, the WMS url to check this behaviour is: http://servizigis.regione.emilia-romagna.it/arcgis/public_sgss/geocatalogo_mappa/MapServer/WMSServer?
We already noticed this behaviour in the past (2009 March) in the 1589 ticket, but then had no time to follow the development.

Thanks,
francesco

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1589

Also available in: Atom PDF