Bug report #15749

Processing: gdal merge converts no data in 0

Added by Paolo Cavallini about 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Processing/GDAL
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23671

Description

gdal merge, as it is used in Processing, converts no data in 0

gdal_merge.py -ot Float32 -o  -of GTiff OUTPUT1.tif OUTPUT2.tif

See sample input and output files: http://www.faunalia.eu/~paolo/merge_null.zip

Previously this did not happen, on the same files.


Related issues

Related to QGIS Application - Bug report #17298: Processing: gdal merge python error on QGIS 3 Closed 2017-10-17

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Assignee changed from Victor Olaya to Giovanni Manghi

#2 Updated by Alexander Bruy about 3 years ago

Looks like there are changes in gdal_merge behaviour. Works fine with GDAL 1.10.1

#3 Updated by Paolo Cavallini about 3 years ago

I had a look to GDAL manpage, and could not spot the change. GDAL 2.1.1+dfsg-5 here.

#4 Updated by Giovanni Manghi almost 3 years ago

  • Target version set to Version 3.0
  • Status changed from Open to In Progress

gdalwarp manual states "The gdalwarp utility is an image mosaicing, reprojection and warping utility",
and in fact it works (to create mosaics) and is much more efficient than gdal_merge.py, not to speak richer of options, one of them the one to pick the nodata from inputs.

We will replace the gdal raster merging tool with gdalwarp then.

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Giovanni Manghi over 2 years ago

  • Description updated (diff)

2.18 fixed here

https://github.com/qgis/QGIS/pull/4918

needs forwardport to master, will do when GDAL is restored in master so I will be able to test.

#7 Updated by Giovanni Manghi about 2 years ago

Giovanni Manghi wrote:

2.18 fixed here

https://github.com/qgis/QGIS/pull/4918

needs forwardport to master, will do when GDAL is restored in master so I will be able to test.

now blocked by #17298

#8 Updated by Jürgen Fischer about 2 years ago

#9 Updated by Paolo Cavallini over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Should be done now.

Also available in: Atom PDF