Bug report #13273

Strange things happen when splitting features

Added by Oskar Karlin almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21333

Description

After updating QGIS to version 2.10.1-Pisa the split feature tool goes nuts! I try to split a line and when I finish the split, the feature completely transforms into something else. See attached image.

This worked fine in last version and the development version that I had installed ( QGIS_2.9-dev 2.9.0-Master (0f35192) )

Screen_Shot_2015-08-27_at_10.46.48.png - Original line (30.4 KB) Oskar Karlin, 2015-08-27 01:50 AM

Screen_Shot_2015-08-27_at_10.47.02.png - After split (77.2 KB) Oskar Karlin, 2015-08-27 01:50 AM

example.zip (10.2 KB) Oskar Karlin, 2015-08-27 06:02 AM


Related issues

Related to QGIS Application - Bug report #13347: Split features and add ring require refreshing the screen... Closed 2015-09-11
Duplicated by QGIS Application - Bug report #13241: split features Closed 2015-08-20

History

#1 Updated by Denis Rouzaud almost 5 years ago

I can't reproduce in master (don't have 2.10).
can you provide some test data?

#2 Updated by Oskar Karlin almost 5 years ago

here's the file.

I also tried the latest nightly from Dakotacartography and the problem occur in that version too.

#3 Updated by Paul Kanelli almost 5 years ago

confirmed (QGIS 2.10.1, Ubuntu 14.04)

#4 Updated by Saber Razmjooei almost 5 years ago

  • OS version deleted (10.10.4)
  • Operating System deleted (Mac OS X)

Another problem #13347 reported with split tool which I think is related.

#5 Updated by Saber Razmjooei almost 5 years ago

  • Category set to Digitising
  • Status changed from Open to Feedback

Could you try with master?

#6 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Reproducable in 2.10 but not in master.

Also available in: Atom PDF