Bug report #12738

After using "difference" consider 2 or more separated polygons as one

Added by Ekaterina Petrunenko over 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.8.2 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20838

Description

This bug (unconvinience) appears while working with vector layers, particularly when counting difference (Vector> Geoprocessing> Difference). Sometimes (it depends on sort of data) after subtracting one polygon from another the result looks like 2 or more separated polygons. But as far as minuend was the one polygon, QGIS consider new separated polygons in a new created layer as one polygon, which is not very comfortable to work with. This can be solved by spliting one of the polygons into two objects, after this operation all separated polygons become really independent and separated. And then we can sew splitted part to its parent polygon again, and finally the work is done. But it will be more comfy to have all polygons independent just after running the difference

History

#1 Updated by Alexander Bruy almost 4 years ago

Please add sample data to reproduce the bug.

From your description it looks like difference produces multiplolygon features, in this case this is not a bug.

#2 Updated by Alexander Bruy almost 4 years ago

  • Category changed from Vectors to 44
  • Status changed from Open to Feedback

#3 Updated by Ekaterina Petrunenko over 3 years ago

Alexander Bruy wrote:

Please add sample data to reproduce the bug.

From your description it looks like difference produces multiplolygon features, in this case this is not a bug.

Thank you! I think, you are right, this operation creates multiplolygon features. Could you please advise civilized way to turn multiplolygon feature into independent polygons?

#4 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Ekaterina Petrunenko wrote:

ould you please advise civilized way to turn multiplolygon feature into independent polygons?

multipart to singleparts in the vector menu.

#5 Updated by Harrissou Santanna over 3 years ago

Might be a feature request, does it sound reasonnable to add a checkbox to the dialog to generate independent single parts polygons instead of multipolygons?

#6 Updated by Giovanni Manghi over 3 years ago

Harrissou Santanna wrote:

Might be a feature request, does it sound reasonnable to add a checkbox to the dialog to generate independent single parts polygons instead of multipolygons?

yes of course.

#7 Updated by Harrissou Santanna over 3 years ago

done in #14870

#8 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF