Bug report #12542

Processing: better naming structure for output

Added by Paolo Cavallini about 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:20684

Description

Currently, outputs are named in different ways, sometimes generic (e.g. Output), sometimes referring to the command who generated it (e.g. Reprojected), sometimes repeating "raster" or "layer", "points" etc.
This is confusing, and appears unpolished. Better decide a general schema.
I'm available to help applying it, once decided.


Related issues

Related to QGIS Application - Feature request #12741: Layer output to file should be loaded inside the TOC with... Open 2015-05-12
Duplicated by QGIS Application - Feature request #12761: More uniform naming of Progessing algs Rejected 2015-05-17

History

#1 Updated by Paolo Cavallini about 5 years ago

My preference:
  • name reflecting the command (e.g. Buffer, Dissolved, Reprojected, etc.)
  • avoid padding words like Output, Layer, Raster, Grid, etc.

#2 Updated by Paolo Cavallini about 5 years ago

  • Subject changed from Processing: bettern naming structure for output to Processing: better naming structure for output

#3 Updated by Paolo Cavallini about 5 years ago

Mostly done for GDAL (ogr still to be done)

#4 Updated by Alexander Bruy about 5 years ago

AFAIK Processing assigns names to the outputs based on the name of the output parameter or using name of the output file (there is an option in the Processing settings for this).

Of course we can edit all algorithms and change labels for outputs, but IMO this is not optimal solution as some algorithms produce multiple outputs and it may be difficult to find short and meaningful names for them. Maybe some generic approach can be used, for example using combination from algorithm and output name, or output name + file name.

#5 Updated by Paolo Cavallini about 5 years ago

I am talking about labels, sorry for the confusion. For labels we are not forced to be very short. I tried with GDAL and some SAGA commands, and I did not find difficult to give understandable names.
The problem is IMHO twofold:
  • calling a resulting raster in many different and uninformative ways (e.g. Raster, Output, Grid, Layer, etc.) is confusing and does not look nice
  • more substantially, it is difficult for the user to select one of the results of previous analyses as an input for further ones, if there is no clue about the origin from the name.
    Please have a look to my recent commits, I believe the situation is much more clear now.
    I do not think an automatic approach can give very good results; the main disadvantage of my proposal it that it takes some times to fix all the output names in a coherent manner.

#6 Updated by Victor Olaya about 5 years ago

  • Status changed from Open to Feedback

Yes, definitely the labels can be changed, and that won't break anything in the execution of algorithms.

As you say, it's a tedious task and requires time, but +1 fro mme if you feel like changing any of them for a better name

#7 Updated by Paolo Cavallini about 5 years ago

Glad you agree. Have you checked what I have done so far? Agreed with that? Main stuff missing is GRASS, where both 6 and 7 should be updated.

#8 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

#9 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

#10 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#11 Updated by Paolo Cavallini over 2 years ago

  • Assignee deleted (Victor Olaya)
  • Resolution set to worksforme
  • Affected QGIS version changed from 2.8.1 to 3.0.0
  • Description updated (diff)
  • Status changed from Open to Closed

Seems good enough now. Feel free to reopen if not.

Also available in: Atom PDF