Bug report #12433

Expression builder dialog becomes too wide because of preview string

Added by Olivier Dalang almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Nathan Woodrow
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows 8.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20604

Description

Hi !

When you enter an expression that has a very long result (eg. geomToWKT( $geometry ) with complex geometries ), the expression builder dialog gets extremely wide (way beyond the screen) because the text doesn't wrap and is displayed completely.
It's annoying because you can't see the OK/Cancel buttons anymore.

Tested under Windows 8.1 and QGIS nightly.

I think the result should be limited to maybe 100 characters ?

Thanks

Thanks !


Related issues

Duplicates QGIS Application - Bug report #12525: Field calculator preview updates layout to a really big u... Closed 2015-04-07

Associated revisions

Revision 204cf751
Added by Nyall Dawson over 4 years ago

Truncate expression preview result in builder widget if too long

Prevents window from resizing to extreme widths (fix #12433)

Revision 8962d843
Added by Nyall Dawson over 4 years ago

Truncate expression preview result in builder widget if too long

Prevents window from resizing to extreme widths (fix #12433)

History

#1 Updated by Nathan Woodrow almost 5 years ago

So enabling wrapping is the correct option that would work here?

#2 Updated by Nathan Woodrow almost 5 years ago

  • Assignee set to Nathan Woodrow

#3 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF