Bug report #12525

Field calculator preview updates layout to a really big unusable window (we need to truncate result preview)

Added by George Rodrigues da Cunha Silva over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Field calculator
Affected QGIS version:2.6.0 Regression?:No
Operating System:Linux Mint Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20669

Description

Hello everyone,

Well, I tried to calculate a new field using the Field Calculator, and I tried to create a text field, 255 length. I assigned it to be the result of the following expression:

geomToWKT($geometry)

When I close the parentheses, the screen updates with the preview result of the expression, enlarging the window to a very big size. This output preview should be truncated when text is larger then a number of characters.

QGIS Version: 2.6;
OS: Linux Mint 17;

Occurs with shapefiles and sqlite. Probably other sources too.

55.png - Nice window (203 KB) George Rodrigues da Cunha Silva, 2015-04-07 05:57 AM

17.png - Bizarre window (1.35 MB) George Rodrigues da Cunha Silva, 2015-04-07 05:57 AM


Related issues

Duplicated by QGIS Application - Bug report #12433: Expression builder dialog becomes too wide because of pre... Closed 2015-03-23

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8 to Version 2.8.2

#2 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#3 Updated by Jürgen Fischer over 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #12433

Also available in: Atom PDF