Bug report #1170

GPS Plugin non-functional (OS X) for Serial Bus/Com port units

Added by John Tull about 12 years ago. Updated over 1 year ago.

Status:Closed
Priority:Low
Assignee:-
Category:C++ plugins/GPS plugin
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:11230

Description

Windows:
When trying to download or upload gpx information from/to a GPS device, nothing happens (error reported about invalid layer when downloading). In order to get gpx download or upload support, you have to manually code the path to the gpx file in the GPS Device settings. E.g., to get a waypoint layer loaded from the GPS device, I have to click on the device settings, go to waypoint download and make the line look like this:
%babel -i garmin -o gpx -f com4 -F "C:\\Documents and Settings\\User Name\\Desktop\\test.gpx" You have to hit "update device" to get this setting to stick. Then I have to fill in the "Save as" box in the main GPS tools dialog with the path to the above test.gpx file. I tell qgis to call the new layer "test", but anything will work here.

OS X:
In OS X, nothing shows up under Port, so you have to code the port into the device settings. In my case, with a serial to usb device, I replace %in (for a download from gps device) with -f /dev/cu.usbserial-ftCASM51. I also had to add -F before %out to get the transfer to actually save the gpx file to disk. (I'm thinking that -F should be added to the %out or %in strings in the C++ code for this plugin.)

Possibly a dev can test this with gps emulation software. The only link for Windows I found was a commercial software with a 14-day free trial called gpsgate.

Serial_Port_drop-down_QGIS.png (11.4 KB) Brian Marriott, 2016-07-29 06:42 PM

Serial_port_drop-down_CoolTerm.png (18.1 KB) Brian Marriott, 2016-07-29 06:42 PM

History

#1 Updated by Paolo Cavallini over 11 years ago

Still true?

#2 Updated by Giovanni Manghi about 11 years ago

Windows:
what version/installer and gps unit did you used?

With the OSGeo4W installer (that installs also gpsbabel) and a Garmin usb unit (gpsmap 60c) it is very straighforward. Just plug the gps unit and qgis will make the connection without the need to change any of the configuration parameters.

Please give feedback.

#3 Updated by Giovanni Manghi about 11 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

Works for me under windows, garmin usb gps, qgis/gpsbabel installed from osgeo4w. Works also under linux.

Feel free to reopen the ticket if there are still issues under Mac.

#4 Updated by John Tull about 11 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Feedback

I'm reopening this and renaming to reflect serial bus usage. If someone can verify that using a serial bus gps unit works, then let's call it done. Otherwise, I think there are problems with com ports/serial bus that have not been resolved. Note that this is not just a Windows problem despite the platform selection in the bug report.

#5 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:4 jctull]:

. Note that this is not just a Windows problem despite the platform selection in the bug report.

Hi, I cannot test the OsX platform, but I can test a serial gps under windows. I'll let you know.

#6 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:4 jctull]:

I'm reopening this and renaming to reflect serial bus usage. If someone can verify that using a serial bus gps unit works, then let's call it done. Otherwise, I think there are problems with com ports/serial bus that have not been resolved. Note that this is not just a Windows problem despite the platform selection in the bug report.

I tested a Garmin eTrex serial GPS unit, used Windows XP, qgis 1.0.2 and 1.2 installed with osgeo4w AND gpsbabel installed also with osgeo4w. It works out of the box with no need of making any change in the configuration of the devices ("edit devices").

I cannot make tests with OsX as I don't have a Mac and I don't know any person that has one and can let me try qgis.

#7 Updated by William Kyngesburye about 11 years ago

I had mixed luck with this a few years ago. I used to build my own gpsbabel + libusb on OSX because there was no other CLI build available. Now I bundle the "official" CLI build in the OSX Qgis, but it's unclear whether they include libusb support.

I have access at work to an old Garmin serial GPS I can try.

#8 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:7 kyngchaos]:

I have access at work to an old Garmin serial GPS I can try.

thanks, let us know.

#9 Updated by Paolo Cavallini over 10 years ago

It is this still true? Please check and confirm, or close it.

#10 Updated by John Tull over 10 years ago

This still does not work on OS X Snow Leopard with latest trunk build of qgis.

#11 Updated by William Kyngesburye over 10 years ago

Well, I can't look into this. Looks like our old serial GPS unit at work died, so I have no way to check it out.

#12 Updated by John Tull over 9 years ago

This problem persists on OS X.

#13 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#14 Updated by Larry Shaffer over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

I can confirm for both 1.7.4RC and latest master that the field for serial device in GPS Tracking is always blank, regardless of whether there is a valid and working /dev serial port. If I hard-code the /dev/cu... path in, then it works, but only for serial GPS interfaces. I've had zero luck with solely-USB connections (with regards to the Tracking feature).

However, the venerable GPS Tools plugin still works fine, even with the solely-USB connected GPS, because I can hard-code the binary path for gpsbabel in the 'Devices' configurations (can't get QGIS to auto-find gpsbabel, regardless of where I put it). So, it appears that the Tracking tool doesn't interface with gpsbabel, but then gpsbabel doesn't do well with live tracking over USB anyways.

There are other libraries out there, as live tracking for the latest USB Garmins, etc. is working. macgpspro.com has it working, though that's proprietary software.

#15 Updated by Larry Shaffer over 8 years ago

Sorry, my report was for Mac Snow Leopard and Lion, QT 4.7.4 and python 2.6.

#16 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#17 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#18 Updated by Giovanni Manghi over 7 years ago

  • Assignee deleted (nobody -)
  • Status info deleted (0)
  • Pull Request or Patch supplied set to No

This new QGIS study

http://www.qgis.org/en/community/qgis-case-studies/new-brunswick-canada.html

seems to show that the GPS plugin is functional under OsX, what is the status of this issue?

#19 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#20 Updated by Jürgen Fischer about 6 years ago

  • Category changed from C++ Plugins to C++ plugins/GPS plugin

#21 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

closing for the lack of feedback

#22 Updated by Brian Marriott about 4 years ago

Re-opening this because the issue described by Larry Shaffer at #note-14 above is still present for me.
I'm using Mac OS X 10.11.6 (15G31), and it shows on both the LTS version (2.14.3-Essen) and the most recently available nightly build from Dakota Cartography (QGIS_2-99-0_2016-07-16_cd3f540).

Symptom is that the drop-down to select the serial port of the GPS appears to be empty, even after a refresh. The reality is that, while it isn't showing any text, each (empty) line is associated with a serial port and is selectable. If you select the right one, you'll link to the GPS. (It looks to me like the text in the drop-down is being extracted from the wrong source in the serial device object.)

I've attached two screen captures - one from QGIS and another from a simple terminal program (CoolTerm). Both show drop-downs populated from the same list of serial ports. If I use the list in CoolTerm to guide which empty line in the QGIS drop-down to select, I can reliably select my GPS serial device.

#23 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#24 Updated by Paolo Cavallini almost 2 years ago

  • Description updated (diff)

Still true?

#25 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Reopened to Feedback
  • Resolution deleted (not reproducable)

#26 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to no timely feedback

Also available in: Atom PDF