Bug report #11351

[composer] combinations of frame/multiframe undo/redo crashes qgis

Added by Nyall Dawson over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:19642

Description

Mixing combinations of frame and multiframe undo and redo operations results in a crash.


Related issues

Related to QGIS Application - Bug report #11371: Map Composer: group + move + ungroup + undo = crash Closed 2014-10-09

Associated revisions

Revision 4ea5c809
Added by Nyall Dawson over 5 years ago

[composer] Avoid crash when using redo on multiframe (fix #11351)

Since multiframe changes can remove and create new frame items,
it's not safe to directly manipulate frame items in
QgsComposerItemCommand. Now, commands which apply to a frame always
fetch a reference to the correct frame item directly from the
parent multiframe. Also added unit tests for this crash.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF