Bug report #10271

Crash when using SVG markers

Added by Gary Sherman over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Symbology
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:18703

Description

With a project containing a lot of SVG marker symbols, zooming and panning will cause QGIS 2.2 (and master) to crash after just a few operations.

Profiling with the dependency walker shows the issue crops up in QTCORE4.DLL:
Second chance exception 0xC0000005 (Access Violation) occurred in "QTCORE4.DLL" at address 0x00000000704C5DC6.

Platform is 64-bit Windows 7 Professional.

Associated revisions

Revision f3ff3b4f
Added by Martin Dobias over 6 years ago

Fix #10271 (crash from race condition in SVG cache when using parallel rendering)

History

#1 Updated by James Harvey over 6 years ago

Make sure you have no other additional elements in the SVG symbols that are outside of the document area. Open them up a vector illustration editor to look. I had some crashing on zooming as well. I noticed that I saved a SVG symbol but had other hidden design elements that were not used and were in the workspace area outside of the artwork area set. I have not had the same issue since I made sure I cleaned out my SVG artwork files.

#2 Updated by Giovanni Manghi over 6 years ago

Hi Gary,

how the project behave in qgis 2.0.1?

#3 Updated by Gary Sherman over 6 years ago

It works fine under 2.0.1

#4 Updated by Giovanni Manghi over 6 years ago

  • Target version changed from Future Release - High Priority to Version 2.4
  • Priority changed from High to Severe/Regression

#5 Updated by Paolo Cavallini over 6 years ago

May be related to #9826 ?

#6 Updated by Giovanni Manghi over 6 years ago

Paolo Cavallini wrote:

May be related to #9826 ?

or #9959-7?

#7 Updated by Martin Dobias over 6 years ago

  • Status changed from Open to Feedback

Please provide some more details, ideally a test project.

#8 Updated by Martin Dobias over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF