Bug report #9826

QGIS 2.2 frequently crashing on ubuntu saucy (13.10) due to styling with svg symbols

Added by Admire Nyakudya over 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:18357

Description

I have a project that i saved in qgis 2.0 and when i try to open it in qgis2.2 the svg symbols i have are not rendered correctly, i have attached a png image for the original svg and what the results look like in qgis 2.2 . when i try to load that layer separately in qgis 2.2 and style it with that the same svg symbol it doesn't draw at all. I have checked with my project if i select all the layers in their individual groups and try to pan around the map it crashes qgis. I have tried to start qgis2.2 from the terminal and i have noticed that each time it crashes there is no stack trace.

svg_errors.png (120 KB) Admire Nyakudya, 2014-03-20 02:39 AM

cultivatedland.svg (25.6 KB) Admire Nyakudya, 2014-03-20 02:39 AM

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Subject changed from QGIS 2.2 frequently crashhing on ubuntu 13.10 due to styling with svg symbols to QGIS 2.2 frequently crashing on ubuntu saucy (13.10) due to styling with svg symbols

#2 Updated by Jürgen Fischer over 6 years ago

  • Category set to Symbology

#3 Updated by Nyall Dawson about 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Please test with a later version and reopen if still an issue. Several changes since 2.2 have likely fixed this issue.

Also available in: Atom PDF